Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
5 registered members (386ka, Yann, Nigel, BBR, 1 invisible), 90 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics109,982
Posts1,306,340
Members2,828
Most Online546
Aug 30th, 2007
Top Posters(All Time)
barnacle 32,184
stan 32,098
Theresa 22,837
bockers 21,013
PeteP 19,120
JimO 17,908
Nigel 17,128
Jim_Clennell 16,329
Vickster 15,915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
20VT timing issues #1633641
30/06/2019 18:09
30/06/2019 18:09
Joined: Dec 2005
Posts: 688
State of Essex .
R
robcoupe20vt Offline OP
Enjoying the ride
robcoupe20vt  Offline OP
Enjoying the ride
R

Joined: Dec 2005
Posts: 688
State of Essex .
Hi have not been able to time my engine . I have the cam locking caps . I bought this car a few months ago and it was off the road for 8 years . Stuck a battery in it and it started . Now i left some spanner son the top of the engine and when it started they were banging so i switched it off . Went to start it again and no joy except the injector light was flashing . I scanned it and it said the camshaft phase was gone . I am thinking the timing may have slipped which would cause the engine not to start and the diagnostic code for the cam sensor to come up. I have had this problem before but on other engine . Can anyone look at the pictures and tell me if its slipped . The srcew driver down number 1 is not AT TDC .

https://i.ibb.co/pKM9Gt0/fiat-coupe-timing-001.jpg

[img]https://i.ibb.co/jzpsGyH/fiat-coupe-timing-002.jpg[/img]

Last edited by robcoupe20vt; 30/06/2019 18:34.

Fiat 20VT
Fiat 16vt
Fiat 130TC
Fiat 131 sport
Kawasaki ZX6R G2
Re: 20VT timing issues [Re: robcoupe20vt] #1633642
30/06/2019 19:46
30/06/2019 19:46
Joined: Sep 2006
Posts: 14,830
FCSS 01684 593187
Countrycruising Offline
Club Rep Europe, member 914
Countrycruising  Offline
Club Rep Europe, member 914
I AM a Coop

Joined: Sep 2006
Posts: 14,830
FCSS 01684 593187
The cams are correct but it's not at TDC on cylinder 1, the locating dowel on the crank pulley is 15-20 degrees out.

Re: 20VT timing issues [Re: robcoupe20vt] #1633646
30/06/2019 20:14
30/06/2019 20:14
Joined: Dec 2005
Posts: 688
State of Essex .
R
robcoupe20vt Offline OP
Enjoying the ride
robcoupe20vt  Offline OP
Enjoying the ride
R

Joined: Dec 2005
Posts: 688
State of Essex .
So you would say the crank timing is out slightly . If thats the case thats why the cam sensor has been flagged as faulty which it most likely is not . I will re time it tomorrow and put the new belts/waterpump on and do a compression check . Thank you


Fiat 20VT
Fiat 16vt
Fiat 130TC
Fiat 131 sport
Kawasaki ZX6R G2
Re: 20VT timing issues [Re: robcoupe20vt] #1633655
01/07/2019 11:05
01/07/2019 11:05
Joined: Sep 2006
Posts: 14,830
FCSS 01684 593187
Countrycruising Offline
Club Rep Europe, member 914
Countrycruising  Offline
Club Rep Europe, member 914
I AM a Coop

Joined: Sep 2006
Posts: 14,830
FCSS 01684 593187
No problem, buy a TDC gauge to be sure it's set at top dead centre, also make sure you're following the belt fitting instructions as instructed on page 87 of the book, if you don't have a copy click on the link below, fingers crossed it's not kissed valves.

Re: 20VT timing issues [Re: robcoupe20vt] #1633660
01/07/2019 16:06
01/07/2019 16:06
Joined: Dec 2005
Posts: 688
State of Essex .
R
robcoupe20vt Offline OP
Enjoying the ride
robcoupe20vt  Offline OP
Enjoying the ride
R

Joined: Dec 2005
Posts: 688
State of Essex .
Update . I checked the timing again this morning and as you say its off . So i took the belt off and reset it just in case the valve to piston contact meant lifting the head . I turned the engine over and it started straight away with the old nelt and tensioners also the injector light went off .The engine sounded fine with no noise or misfire I had a new cam phase sensor and fitted that also . When i put the timing belt kit/water pump and the phase sensor it started again . So i pulled the plugs and did a compression check just to be on the safe side .

As in the picture 150psi on all five so i am very lucky as i reckon the belt had moved 2 to 3 tooth . If the head had needed to come off i was going to park it in the corner and start back on my 16VT . Lesson learnt this car had been parked for 8 years and the tensioner has got stuck and made the belt slack this is why the belt jumped . I have been doing 20 vt timing belt changes since 2002 last one on my brothers coupe about 3 years ago but having done many other difficult cars the coupe is a peice of cake .

click to enlarge
click to enlarge
click to enlarge
click to enlarge
click to enlarge

Last edited by Edinburgh; 01/07/2019 16:30. Reason: fixed thumbnails

Fiat 20VT
Fiat 16vt
Fiat 130TC
Fiat 131 sport
Kawasaki ZX6R G2
Re: 20VT timing issues [Re: robcoupe20vt] #1633666
01/07/2019 20:33
01/07/2019 20:33
Joined: Sep 2006
Posts: 14,830
FCSS 01684 593187
Countrycruising Offline
Club Rep Europe, member 914
Countrycruising  Offline
Club Rep Europe, member 914
I AM a Coop

Joined: Sep 2006
Posts: 14,830
FCSS 01684 593187
Sounds like a lucky escape.

Out of interest do you undo the exhaust pulley bolt?

Re: 20VT timing issues [Re: robcoupe20vt] #1633671
01/07/2019 22:20
01/07/2019 22:20
Joined: Dec 2005
Posts: 688
State of Essex .
R
robcoupe20vt Offline OP
Enjoying the ride
robcoupe20vt  Offline OP
Enjoying the ride
R

Joined: Dec 2005
Posts: 688
State of Essex .
Yes very very lucky . I had to take the exhaust cam wheel off to fit the cam phase sensor


Fiat 20VT
Fiat 16vt
Fiat 130TC
Fiat 131 sport
Kawasaki ZX6R G2

Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.7 Page Time: 0.014s Queries: 14 (0.006s) Memory: 0.7775 MB (Peak: 0.8627 MB) Data Comp: Off Server Time: 2019-07-24 08:27:46 UTC