Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
0 registered members (), 106 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics110,264
Posts1,309,116
Members2,888
Most Online546
Aug 30th, 2007
Top Posters(All Time)
barnacle 32,269
stan 32,098
Theresa 22,880
bockers 21,019
PeteP 19,244
JimO 17,908
Nigel 17,186
Jim_Clennell 16,342
Vickster 15,915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
Coolant gauge not working #1633765
07/07/2019 05:15
07/07/2019 05:15
Joined: May 2017
Posts: 101
Vinisce
D
Dorian Offline OP
On a journey
Dorian  Offline OP
On a journey
D

Joined: May 2017
Posts: 101
Vinisce
Greetings, my coolant gauge is not working anymore-it sits at it's lowest point and doesn't move not even a bit. Which sensor is at fault(heard that there are two) and can I drive the car with it broken,by that I mean will the car turn on the fan or overheat when I get into trafic. Car is 2.0 16v. Thanks in advance

Re: Coolant gauge not working [Re: Dorian] #1633766
07/07/2019 07:13
07/07/2019 07:13
Joined: Dec 2005
Posts: 32,269
Hemel in the Hempstead
barnacle Offline
Club Member 18 - ex-Minister without Portfolio
barnacle  Offline
Club Member 18 - ex-Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,269
Hemel in the Hempstead
The sensor for the gauge (part 61) is on the low rear of the thermostat; it has a single connector and it's screwed in from the side. The ECU sensor (part 28) is on the top of the thermostat, and has two contacts. It's completely independent of the gauge sensor so unless you have reason to believe that there is a common issue (e.g. complete absence of coolant!) you will be able to drive as normal.

The fans are controlled by a thermo switch on the side of the radiator, so they work purely on coolant temperature.


[Linked Image]
Don't get no respect! [b]Coupe Fiat 1994-2000 - an owner's guide[/b] <-- clicky!
Re: Coolant gauge not working [Re: barnacle] #1633769
07/07/2019 16:10
07/07/2019 16:10
Joined: May 2017
Posts: 101
Vinisce
D
Dorian Offline OP
On a journey
Dorian  Offline OP
On a journey
D

Joined: May 2017
Posts: 101
Vinisce
Thanks for the reply,thankfully for some reason it started working again xD.

Re: Coolant gauge not working [Re: Dorian] #1633770
07/07/2019 18:01
07/07/2019 18:01
Joined: Dec 2005
Posts: 32,269
Hemel in the Hempstead
barnacle Offline
Club Member 18 - ex-Minister without Portfolio
barnacle  Offline
Club Member 18 - ex-Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,269
Hemel in the Hempstead
Check the terminal connector on the wire. They have been known to break where the wire is crimped.


[Linked Image]
Don't get no respect! [b]Coupe Fiat 1994-2000 - an owner's guide[/b] <-- clicky!

Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.9 Page Time: 0.014s Queries: 14 (0.007s) Memory: 0.7564 MB (Peak: 0.8034 MB) Data Comp: Off Server Time: 2019-11-21 01:26:37 UTC