Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
0 registered members (), 100 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics110,132
Posts1,307,836
Members2,860
Most Online546
Aug 30th, 2007
Top Posters(All Time)
barnacle 32,248
stan 32,098
Theresa 22,857
bockers 21,015
PeteP 19,196
JimO 17,908
Nigel 17,172
Jim_Clennell 16,338
Vickster 15,915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
20VT Issue #1635170
01/09/2019 14:51
01/09/2019 14:51
Joined: Apr 2012
Posts: 67
wolverhampton
N
n3v3ragain Offline OP
Reaping the fruits
n3v3ragain  Offline OP
Reaping the fruits
N

Joined: Apr 2012
Posts: 67
wolverhampton
Hi

Last week whilst driving my 20VT started revving by itself up to 3000RPM, back down to 900 then back up to 3000.

It will drive ok when in gear but as soon as clutch pedal is pressed or out of gear it does the same,

No injector lights, perfect oil pressure and starts first time,

I don't think its the ICV purely because of the high revs its going up to?

Any ideas guys ?

Last edited by n3v3ragain; 01/09/2019 14:55.
Re: 20VT Issue [Re: n3v3ragain] #1635172
01/09/2019 16:13
01/09/2019 16:13
Joined: Mar 2008
Posts: 4,382
highlands
jimboy Offline
Club Member 857
jimboy  Offline
Club Member 857
Forum is my job

Joined: Mar 2008
Posts: 4,382
highlands
Boost leak somewhere perhaps.


I'm an old git & happy with it,most of the time
Re: 20VT Issue [Re: n3v3ragain] #1635188
01/09/2019 18:54
01/09/2019 18:54
Joined: Dec 2005
Posts: 32,248
Hemel in the Hempstead
barnacle Offline
Club Member 18 - ex-Minister without Portfolio
barnacle  Offline
Club Member 18 - ex-Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,248
Hemel in the Hempstead
Check the throttle position valve and its connector.


[Linked Image]
Don't get no respect! [b]Coupe Fiat 1994-2000 - an owner's guide[/b] <-- clicky!

Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.9 Page Time: 0.011s Queries: 14 (0.005s) Memory: 0.7475 MB (Peak: 0.7914 MB) Data Comp: Off Server Time: 2019-09-21 02:29:44 UTC