Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
3 registered members (bayliss, cyborg7, PaulL), 196 guests, and 4 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics110,265
Posts1,309,145
Members2,888
Most Online546
Aug 30th, 2007
Top Posters(All Time)
barnacle 32,269
stan 32,098
Theresa 22,880
bockers 21,019
PeteP 19,246
JimO 17,908
Nigel 17,186
Jim_Clennell 16,342
Vickster 15,915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
Car cranks but won't start #1636783
10/11/2019 20:47
10/11/2019 20:47
Joined: Dec 2005
Posts: 721
t0m0 Offline OP
Enjoying the ride
t0m0  Offline OP
Enjoying the ride

Joined: Dec 2005
Posts: 721
Hi all, I don't post on here much but do drop in a read every week and having had some spare time this weekend decided to look at the coop that's been sat for a few years sorn. I fired her up 3 or 4 months ago and she was fine although the clutch took a few pumps to get pressure and the engine was a bit tappy at first however this weekend she just wouldn't fire after cranking☹️.

Three cans of fresh petrol and I clicked and unclicked the fuel cut off. The code light goes out after the light up sequence so I'm sure it's not this.

The fuel guage says that there is no petrol in the tank and the low fuel light is on and I can not here the pump priming..... does this point to a blocked or dead fuel pump? ....last time I fired her up and drove her back and forward and let her idle then rev for ages and she was already low on fuel.....I know🙄.

Any advice most welcome, Tom.

Re: Car cranks but won't start [Re: t0m0] #1636790
11/11/2019 09:27
11/11/2019 09:27
Joined: Sep 2006
Posts: 14,902
FCSS 01684 593187
Countrycruising Offline
Club Rep Europe, member 914
Countrycruising  Offline
Club Rep Europe, member 914
I AM a Coop

Joined: Sep 2006
Posts: 14,902
FCSS 01684 593187
Can you here the relay click to prime the fuel pump when you turn the ignition on, you should hear a click/click from the passenger foot well?

Re: Car cranks but won't start [Re: t0m0] #1636808
12/11/2019 22:08
12/11/2019 22:08
Joined: Dec 2005
Posts: 721
t0m0 Offline OP
Enjoying the ride
t0m0  Offline OP
Enjoying the ride

Joined: Dec 2005
Posts: 721
Thanks Joe, will listen the weekend. Where is it located if I need to check it's in tight or needs replacing?

Tom.


Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.9 Page Time: 0.013s Queries: 14 (0.006s) Memory: 0.7521 MB (Peak: 0.7932 MB) Data Comp: Off Server Time: 2019-11-22 22:26:51 UTC