Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
0 registered members (), 88 guests, and 6 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics110,325
Posts1,309,679
Members2,149
Most Online546
Aug 30th, 2007
Top Posters(All Time)
barnacle 32,274
stan 32,098
Theresa 22,890
bockers 21,019
PeteP 19,304
JimO 17,908
Nigel 17,192
Jim_Clennell 16,345
nismo 15,137
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
Car cranks but won't start #1636783
10/11/2019 20:47
10/11/2019 20:47
Joined: Dec 2005
Posts: 722
t0m0 Offline OP
Enjoying the ride
t0m0  Offline OP
Enjoying the ride

Joined: Dec 2005
Posts: 722
Hi all, I don't post on here much but do drop in a read every week and having had some spare time this weekend decided to look at the coop that's been sat for a few years sorn. I fired her up 3 or 4 months ago and she was fine although the clutch took a few pumps to get pressure and the engine was a bit tappy at first however this weekend she just wouldn't fire after cranking☹️.

Three cans of fresh petrol and I clicked and unclicked the fuel cut off. The code light goes out after the light up sequence so I'm sure it's not this.

The fuel guage says that there is no petrol in the tank and the low fuel light is on and I can not here the pump priming..... does this point to a blocked or dead fuel pump? ....last time I fired her up and drove her back and forward and let her idle then rev for ages and she was already low on fuel.....I know🙄.

Any advice most welcome, Tom.

Re: Car cranks but won't start [Re: t0m0] #1636790
11/11/2019 09:27
11/11/2019 09:27
Joined: Sep 2006
Posts: 14,915
FCSS 01684 593187
Countrycruising Offline
Club Rep Europe, member 914
Countrycruising  Offline
Club Rep Europe, member 914
I AM a Coop

Joined: Sep 2006
Posts: 14,915
FCSS 01684 593187
Can you here the relay click to prime the fuel pump when you turn the ignition on, you should hear a click/click from the passenger foot well?

Re: Car cranks but won't start [Re: t0m0] #1636808
12/11/2019 22:08
12/11/2019 22:08
Joined: Dec 2005
Posts: 722
t0m0 Offline OP
Enjoying the ride
t0m0  Offline OP
Enjoying the ride

Joined: Dec 2005
Posts: 722
Thanks Joe, will listen the weekend. Where is it located if I need to check it's in tight or needs replacing?

Tom.

Re: Car cranks but won't start [Re: t0m0] #1637117
27/11/2019 22:13
27/11/2019 22:13
Joined: Dec 2005
Posts: 722
t0m0 Offline OP
Enjoying the ride
t0m0  Offline OP
Enjoying the ride

Joined: Dec 2005
Posts: 722
Hi all,

Ok found the 2 relays one black one red tonight when I had 5 mins. Both fuses look ok.

What are the relays related to? I assume one is fuel pump).


I turned ignition on and there is a click,click from that area especially as they hanging after fuse check. I did not try to crank as it 9.30 at night but will the weekend...if she starts I like to run to temp.

When the ignition is on the fuel guage stays at the bottom despite £15 of petrol. And low warning light is on is this normal or should it raise to a level?

I suspect blocked fuel pump as I can't hear priming although I might hook up pump to a direct feed spare battery.

Any advice welcome,

Tom.

Re: Car cranks but won't start [Re: t0m0] #1637122
28/11/2019 11:15
28/11/2019 11:15
Joined: Sep 2006
Posts: 14,915
FCSS 01684 593187
Countrycruising Offline
Club Rep Europe, member 914
Countrycruising  Offline
Club Rep Europe, member 914
I AM a Coop

Joined: Sep 2006
Posts: 14,915
FCSS 01684 593187
If you can't hear the pump priming but the relay is clicking it's either the yellow connector of death or the pump has failed so try the direct feed and report back thumb


Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.12 Page Time: 0.012s Queries: 14 (0.006s) Memory: 0.7612 MB (Peak: 0.8176 MB) Data Comp: Off Server Time: 2019-12-14 05:59:59 UTC