Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
2 registered members (Rob07, Just_Matthew), 53 guests, and 4 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums64
Topics112,027
Posts1,325,365
Members2,206
Most Online731
Jan 14th, 2020
Top Posters(All Time)
barnacle 32,916
stan 32,112
Theresa 23,138
bockers 21,041
PeteP 20,471
JimO 17,917
Nigel 17,318
Jim_Clennell 16,574
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
Passed MOT but... #1654425
26/11/2021 22:46
26/11/2021 22:46
Joined: Mar 2006
Posts: 1,195
Warrington
G_Man Offline OP
Club Member 1656
G_Man  Offline OP
Club Member 1656
Enjoying the ride

Joined: Mar 2006
Posts: 1,195
Warrington
Yay passed MOT but my flippin injector light is still stuck on but car running smoothly at the moment. Collect on Monday but this has been a saga that started back in mid-July and has really tested my patience grr

Last edited by G_Man; 26/11/2021 22:47.

77 77
Re: Passed MOT but... [Re: G_Man] #1654426
27/11/2021 01:25
27/11/2021 01:25
Joined: Mar 2007
Posts: 13,569
Auld Reekie
Edinburgh Offline
Club President
Edinburgh  Offline
Club President
I AM a Coop

Joined: Mar 2007
Posts: 13,569
Auld Reekie
This is a deal more progress than a couple of weeks back Alan, good news thumb

Was it a sensor in the end?


BumbleBee back:)
Re: Passed MOT but... [Re: G_Man] #1654442
28/11/2021 12:43
28/11/2021 12:43
Joined: Jun 2008
Posts: 1,163
Kent, South East
Cooperman Offline
Club Membership Secretary
Cooperman  Offline
Club Membership Secretary
Enjoying the ride

Joined: Jun 2008
Posts: 1,163
Kent, South East
Great news on the MOT Alan thumb


[Linked Image]
Re: Passed MOT but... [Re: G_Man] #1654443
28/11/2021 13:51
28/11/2021 13:51
Joined: Mar 2008
Posts: 4,790
highlands
jimboy Offline
Club Member 857
jimboy  Offline
Club Member 857
Forum is my job

Joined: Mar 2008
Posts: 4,790
highlands
Aye, another year on the road. My Coops MOT is tomorrow, fingers crossed… driving


I'm an old git & happy with it,most of the time
Re: Passed MOT but... [Re: Edinburgh] #1654475
29/11/2021 10:16
29/11/2021 10:16
Joined: Mar 2006
Posts: 1,195
Warrington
G_Man Offline OP
Club Member 1656
G_Man  Offline OP
Club Member 1656
Enjoying the ride

Joined: Mar 2006
Posts: 1,195
Warrington
Hi Simon - everything points to the cam / phase sensor but STILL not resolved crazy

@ Jimboy - hope your MOT goes OK thumb

Last edited by G_Man; 29/11/2021 10:16.

77 77
Re: Passed MOT but... [Re: G_Man] #1654496
29/11/2021 18:27
29/11/2021 18:27
Joined: Dec 2005
Posts: 7,715
Lightwater, Surrey UK
DaveG Offline
Club Member 311
DaveG  Offline
Club Member 311
Je suis un Coupé

Joined: Dec 2005
Posts: 7,715
Lightwater, Surrey UK
Alan, have you read any fault codes? If you had a 20vt I would get you to check the electrical connection to the EBV, but you don't have one of them. Is it running cold perchance with a failed thermostat?

But if everything points to cam/phase sensor and you haven't changed it...well, why don't you try that?


1996 Portofino 20vt & 2000 Pearl White Plus
1985½ & 2016 2017 Fiat 124 Spider + XF Sportbrake
Re: Passed MOT but... [Re: DaveG] #1654501
29/11/2021 20:41
29/11/2021 20:41
Joined: Mar 2006
Posts: 1,195
Warrington
G_Man Offline OP
Club Member 1656
G_Man  Offline OP
Club Member 1656
Enjoying the ride

Joined: Mar 2006
Posts: 1,195
Warrington
I know Dave but new cam sensors are no longer available for 16v's but has been cleaned and apparently was all good. Initially diagnosed as a faulty ECU but was replaced by a cloned unit but the fault persists so now got a spare ECU for the coupe rolleyes


77 77
Re: Passed MOT but... [Re: G_Man] #1654505
29/11/2021 21:31
29/11/2021 21:31
Joined: Mar 2007
Posts: 13,569
Auld Reekie
Edinburgh Offline
Club President
Edinburgh  Offline
Club President
I AM a Coop

Joined: Mar 2007
Posts: 13,569
Auld Reekie
So is the injector light still on Alan?


BumbleBee back:)
Re: Passed MOT but... [Re: G_Man] #1654507
29/11/2021 21:49
29/11/2021 21:49
Joined: Mar 2019
Posts: 192
North Macedonia
386ka Offline
Club Member 1814
386ka  Offline
Club Member 1814
On a journey

Joined: Mar 2019
Posts: 192
North Macedonia
If it's a 16v NA, then I think the sensor is a VR one, so two pins only. You probably won't find the whole sensor with housing, however the internal sensor should be replaceable.
See this - I think it fits the Coupe too: https://www.deltaintegrale.com/shop/delta-integrale-16v-engine-electrical/9940429

Neil and Joe might be able to offer further help on that

Last edited by 386ka; 29/11/2021 21:50.
Re: Passed MOT but... [Re: 386ka] #1654529
30/11/2021 18:00
30/11/2021 18:00
Joined: Sep 2006
Posts: 15,881
FCSS 01684 593187
Countrycruising Offline
Club Rep Europe, member 914
Countrycruising  Offline
Club Rep Europe, member 914
Forum veteran

Joined: Sep 2006
Posts: 15,881
FCSS 01684 593187
Originally Posted by 386ka
If it's a 16v NA, then I think the sensor is a VR one, so two pins only. You probably won't find the whole sensor with housing, however the internal sensor should be replaceable.
See this - I think it fits the Coupe too: https://www.deltaintegrale.com/shop/delta-integrale-16v-engine-electrical/9940429

Neil and Joe might be able to offer further help on that


That design doesn't fit the Coupe 16v models, I have another supplier so have organised one for Alan so it'll be with me for the Xmas meet in Carlisle.


Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.33 Page Time: 0.019s Queries: 15 (0.008s) Memory: 0.7862 MB (Peak: 0.8853 MB) Data Comp: Off Server Time: 2022-01-19 14:53:48 UTC