Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
2 registered members (Nigel, french_coupe), 39 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics110,056
Posts1,307,116
Members2,844
Most Online546
Aug 30th, 2007
Top Posters(All Time)
barnacle 32,218
stan 32,098
Theresa 22,849
bockers 21,013
PeteP 19,170
JimO 17,908
Nigel 17,155
Jim_Clennell 16,332
Vickster 15,915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
Code light and injector light on constantly #1632521
14/05/2019 22:35
14/05/2019 22:35
Joined: Jun 2018
Posts: 41
England
Forfoot30 Offline OP
Discoverer
Forfoot30  Offline OP
Discoverer

Joined: Jun 2018
Posts: 41
England
Evening gents

To cut a long story semi short was driving home yesterday the coupe felt as if it cut out whilst driving revs dropped and then picked up again pulled over and it cut out started again fine so drove home turned it off whilst sorting my wheels but left boot and door open I thought the battery had died as it would not start after this bought a new battery today put it on and still won't fire and I have the code light and injector light on constantly any ideas as to where I can start

Thanks Chris

Re: Code light and injector light on constantly [Re: Forfoot30] #1632524
15/05/2019 07:54
15/05/2019 07:54
Joined: Jun 2018
Posts: 41
England
Forfoot30 Offline OP
Discoverer
Forfoot30  Offline OP
Discoverer

Joined: Jun 2018
Posts: 41
England
Update

All fuel related relays no longer click constantly
Rad fans cut in with ignition on then the top yellow relay clicks and they cut out
Attempts to run but then continues to turn over
Plugs are wet so I'm getting fuel
After turning ignition on last night there was a loud pop/bang from the rear right hand side of the car

I'm really stumped on this so any help would much appreciated


Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.8 Page Time: 0.012s Queries: 15 (0.006s) Memory: 0.7459 MB (Peak: 0.7822 MB) Data Comp: Off Server Time: 2019-08-23 15:11:41 UTC