Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
2 registered members (cecil, JRibeiro), 80 guests, and 0 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics110,055
Posts1,307,091
Members2,844
Most Online546
Aug 30th, 2007
Top Posters(All Time)
barnacle 32,217
stan 32,098
Theresa 22,849
bockers 21,013
PeteP 19,168
JimO 17,908
Nigel 17,155
Jim_Clennell 16,332
Vickster 15,915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
Rear fog light not working.... #1634570
09/08/2019 18:45
09/08/2019 18:45
Joined: Jun 2008
Posts: 65
Ireland
aaronmac Offline OP
Reaping the fruits
aaronmac  Offline OP
Reaping the fruits

Joined: Jun 2008
Posts: 65
Ireland
Hi all, back working on my 20vt getting her up to speed for the national car test (mot). The rear fog won't work (with headlights on).

No light on the dash along with no rear fog obviously smile I checked amd could feel no relay pulsing... I then checked the VIS coupe I have and the relay that pulses is missing from the turbo!

I put that relay into the turbo and it pulses now on pressing the switch, but still no dash light illuminating or fogs.... Very strange.... Any ideas?

Last edited by aaronmac; 09/08/2019 18:55.
Re: Raer fog light not working.... [Re: aaronmac] #1634571
09/08/2019 18:50
09/08/2019 18:50
Joined: Jun 2008
Posts: 65
Ireland
aaronmac Offline OP
Reaping the fruits
aaronmac  Offline OP
Reaping the fruits

Joined: Jun 2008
Posts: 65
Ireland
In case it's some weird wiring issue that would be a pain to fix, I also bought a fused fog light kit with relay... If all else fails it will be taking up residence in the coin holder slot, its actually almost a perfect fit and should look stock with a bit of milling on the corners..

I tested it all and it works great, however I'd like to know the easiest amd shortest route from the transmission tunnel to the fog... I already have the centre console and handbrake tunnel removed as I'm refurbing them... Ideally I'd like to go under the carpet at the handbrake and into the boot but not sure how difficult this would be?

Re: Raer fog light not working.... [Re: aaronmac] #1634581
09/08/2019 21:21
09/08/2019 21:21
Joined: Jun 2008
Posts: 65
Ireland
aaronmac Offline OP
Reaping the fruits
aaronmac  Offline OP
Reaping the fruits

Joined: Jun 2008
Posts: 65
Ireland
Fits nicely now.... Any help on the wiring path back to the fog light, or ideas on why my original fog switch isn't working would be greatly appreciated...

Attached Files
Re: Raer fog light not working.... [Re: aaronmac] #1634583
09/08/2019 21:24
09/08/2019 21:24
Joined: Apr 2010
Posts: 1,004
norwich, norfolk
adam16vt Offline
Enjoying the ride
adam16vt  Offline
Enjoying the ride

Joined: Apr 2010
Posts: 1,004
norwich, norfolk
Have you actually tested the fog light switch?

Re: Raer fog light not working.... [Re: aaronmac] #1634584
09/08/2019 21:26
09/08/2019 21:26
Joined: Jun 2008
Posts: 65
Ireland
aaronmac Offline OP
Reaping the fruits
aaronmac  Offline OP
Reaping the fruits

Joined: Jun 2008
Posts: 65
Ireland
Yep switched that 3 button unit with the vis unit and no go... Also replaced wihh a brand new switch from amazon UK of all places and still no dice.... Strange that its pulsing the relay but no symbol on dash, and yes, I'm trying with the headlights on.... So annoying!

Re: Raer fog light not working.... [Re: aaronmac] #1634587
09/08/2019 23:49
09/08/2019 23:49
Joined: Mar 2007
Posts: 10,753
Auld Reekie
Edinburgh Offline
Club Board member
Edinburgh  Offline
Club Board member
I AM a Coop

Joined: Mar 2007
Posts: 10,753
Auld Reekie
Originally Posted by aaronmac
Fits nicely now.... Any help on the wiring path back to the fog light, or ideas on why my original fog switch isn't working would be greatly appreciated...


Feed it rearwards under the carpet having removed the rear seat squab (2 x M6 hex bolts), you'll easily route it into the boot.



Er, you "have" checked the fog light bulb?

Last edited by Edinburgh; 09/08/2019 23:51.

[Linked Image]

So there, Photobucket...
Re: Raer fog light not working.... [Re: Edinburgh] #1634588
10/08/2019 00:18
10/08/2019 00:18
Joined: Jun 2008
Posts: 65
Ireland
aaronmac Offline OP
Reaping the fruits
aaronmac  Offline OP
Reaping the fruits

Joined: Jun 2008
Posts: 65
Ireland
Cheers, that's great to know it'll be that easy, saves alot of headache, thanks...

Yeah I've switched in and out a few diff bulbs... Find it strange that it wouldn't illuminate the dash light for it, I wonder if there is an earthing issue from the relay to the dash/fog light or a connection is corroded... I don't really know much about behind the scenes car electrics tbh.....

Re: Raer fog light not working.... [Re: aaronmac] #1634596
10/08/2019 09:09
10/08/2019 09:09
Joined: Sep 2006
Posts: 14,859
FCSS 01684 593187
Countrycruising Offline
Club Rep Europe, member 914
Countrycruising  Offline
Club Rep Europe, member 914
I AM a Coop

Joined: Sep 2006
Posts: 14,859
FCSS 01684 593187
Be aware for the MOT test the dash light must eliminate, also did you check the relay?

Re: Raer fog light not working.... [Re: Countrycruising] #1634629
11/08/2019 03:11
11/08/2019 03:11
Joined: Jun 2008
Posts: 65
Ireland
aaronmac Offline OP
Reaping the fruits
aaronmac  Offline OP
Reaping the fruits

Joined: Jun 2008
Posts: 65
Ireland
There actually was no relay there, I stuck the fog relay from the vis I have, but no joy, it clicks but nothing.. What else does that relay control out of interest?

Thankfully the NCT here requires that the dash light illuminates or the instrument switch lights to show it's powered on, which this one does, along with a near identical red back light.. I'll upload a pic when I wire it up when the rain stops lashing down....

Re: Rear fog light not working.... [Re: aaronmac] #1634630
11/08/2019 03:22
11/08/2019 03:22
Joined: Jun 2008
Posts: 65
Ireland
aaronmac Offline OP
Reaping the fruits
aaronmac  Offline OP
Reaping the fruits

Joined: Jun 2008
Posts: 65
Ireland
This the lil kit and I'm using a piggy back fuse from the dips or fulls... Those piggy back fuses are well handy, how long are they around?!

Also has me thinking, when I hopefully fix the stock switch/wiring, or pass the test and wait for another year, what could I connect that switch up to in the boot or rear shelf.... Something useful or cool/quirky?!!

Attached Files
Re: Rear fog light not working.... [Re: aaronmac] #1634633
11/08/2019 09:41
11/08/2019 09:41
Joined: Dec 2005
Posts: 3,657
Pothole City
GrahamL Offline
Forum is my job
GrahamL  Offline
Forum is my job

Joined: Dec 2005
Posts: 3,657
Pothole City
There are different fuse box variants between 20vt's, never mind between a VIS and 20vt, so you can't assume anything is in the same place.

Probably just the relay, if you can find it, assuming that the fog light ever worked at all.

Re: Rear fog light not working.... [Re: GrahamL] #1634640
11/08/2019 14:17
11/08/2019 14:17
Joined: Jun 2008
Posts: 65
Ireland
aaronmac Offline OP
Reaping the fruits
aaronmac  Offline OP
Reaping the fruits

Joined: Jun 2008
Posts: 65
Ireland
Yeah sometimes I wonder is it whatever they had to closest to hand in the factory..... I've never seen it work anyway! Hopefully it's something simply... If anyone has a 1998 20vt that would be kind enough to locate their relay and share, I'd appreciate it...

Re: Rear fog light not working.... [Re: aaronmac] #1634642
11/08/2019 16:09
11/08/2019 16:09
Joined: Mar 2007
Posts: 10,753
Auld Reekie
Edinburgh Offline
Club Board member
Edinburgh  Offline
Club Board member
I AM a Coop

Joined: Mar 2007
Posts: 10,753
Auld Reekie
Do you have access to the schematics? You said you tested it all....so there is power to the lamp....


[Linked Image]

So there, Photobucket...
Re: Rear fog light not working.... [Re: aaronmac] #1634643
11/08/2019 16:14
11/08/2019 16:14
Joined: Jun 2008
Posts: 65
Ireland
aaronmac Offline OP
Reaping the fruits
aaronmac  Offline OP
Reaping the fruits

Joined: Jun 2008
Posts: 65
Ireland
No I don't unfortunately, Internet is terrible here, only patchy 3G...

I didn't stick a multimeter to it yet but tried 4 bulbs and no go.....although all 4 are probably faulty... I have a different lamp connector I'll swap in..

Re: Rear fog light not working.... [Re: aaronmac] #1634644
11/08/2019 16:19
11/08/2019 16:19
Joined: Dec 2005
Posts: 3,657
Pothole City
GrahamL Offline
Forum is my job
GrahamL  Offline
Forum is my job

Joined: Dec 2005
Posts: 3,657
Pothole City
Ah OK, if fog lamp has never worked then maybe the relay was just missing then, possibly removed by previous owner trying to fix the same problem even.

Re: Rear fog light not working.... [Re: aaronmac] #1634654
11/08/2019 23:37
11/08/2019 23:37
Joined: Mar 2007
Posts: 10,753
Auld Reekie
Edinburgh Offline
Club Board member
Edinburgh  Offline
Club Board member
I AM a Coop

Joined: Mar 2007
Posts: 10,753
Auld Reekie
Originally Posted by aaronmac
No I don't unfortunately, Internet is terrible here, only patchy 3G...

I didn't stick a multimeter to it yet but tried 4 bulbs and no go.....although all 4 are probably faulty... I have a different lamp connector I'll swap in..


Well I'm no spark but you should check there is current actually going to it...

And you have checked the fuse (in the bank above the accelerator pedal) which "should" be no. 11, 7.5 amp? It controls both the lamp and the warning lamp....


[Linked Image]

So there, Photobucket...

Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.8 Page Time: 0.019s Queries: 17 (0.007s) Memory: 0.8241 MB (Peak: 0.9603 MB) Data Comp: Off Server Time: 2019-08-21 09:44:52 UTC