Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey & James Northam - Funded by the Club for the benefit of all owners -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fiatcoupeclub.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
1 registered (BBR), 50 Guests and 8 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
2,607 Registered Members
65 Forums
108,872 Topics
1,295,489 Posts

Most users ever online: 546 @ 30/08/2007 19:16
Top Posters
stan 32079
barnacle 31764
Theresa 22716
bockers 20994
pinin_prestatyn 19865
PeteP 18589
JimO 17908
Nigel 16870
Jim_Clennell 16223
Vickster 15915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1605572 - 03/08/2017 18:59 No wipers/blowers/AC
andyleesy Offline
Reaping the fruits

Registered: 28/04/2014
Posts: 82
Loc: Leicestershire
Hi,

I have just picked up a Fiat Coupe that hasn't done a great deal for he past few years.
The wipers don't work, neither do the AC or blowers.
I've located the fuse inside and it's blown. Replaced it, tried the wipers and instantly blown.
Where should I start? The stalk could be suspect? If so how does the cowling come off - I undid the screws but it didn't want to budge....

Any help appreciated.

Thanks

Top
#1605574 - 03/08/2017 20:16 Re: No wipers/blowers/AC [Re: andyleesy]
andyleesy Offline
Reaping the fruits

Registered: 28/04/2014
Posts: 82
Loc: Leicestershire
Fuses inside engine bay are fine

Top
#1605595 - 04/08/2017 09:41 Re: No wipers/blowers/AC [Re: andyleesy]
GrahamL Offline
I need some sleep

Registered: 17/12/2005
Posts: 3471
Loc: Pothole City
First, buy a pack of fuses! smile

Fit a new fuse and test each item on the affected circuits one at a time, replacing the fuse each time it blows. That way you'll know exactly which circuit(s) have a fault.

Having identified what's causing the fault you'll then need to trace and check the wiring. Disconnect at the device end and test again, if fuse still blows then fault is with the wiring, if not then it's the device itself.

If the wiring has a connector at some point (most will go through at least one big multi-way plug) then disconnect there and test each side for a short to ground to narrow down the fault.

The only common place for wires to short is by rubbing on the frame of the radio behind the centre console, so I'd start there.

Top
#1605610 - 04/08/2017 14:08 Re: No wipers/blowers/AC [Re: andyleesy]
Edinburgh Offline
Club member 225
Je suis un Coupé

Registered: 04/03/2007
Posts: 9957
Loc: Auld Reekie
Originally Posted By andyleesy
The stalk could be suspect? If so how does the cowling come off - I undid the screws but it didn't want to budge...

Thanks


I would go with Graham's advice and leave the indicator stalk assembly - I've changed a number of these and apart from the old chestnut of non-cancelling indicators there's not a lot tends to go wrong there.

It's more likely a short from a frayed wire.
_________________________


So there, Photobucket...

Top
#1605638 - 05/08/2017 21:02 Re: No wipers/blowers/AC [Re: andyleesy]
andyleesy Offline
Reaping the fruits

Registered: 28/04/2014
Posts: 82
Loc: Leicestershire
Thanks both.
I've had a look but I suspect it'll be near the wiper motor (although wires shouldn't be shorting there really as it's under the scuttle isn't it?)
I've handed it to an auto-sparky to find/fix depending.
I'll update once I know what it is.

Top
#1605785 - 08/08/2017 19:49 Re: No wipers/blowers/AC [Re: andyleesy]
andyleesy Offline
Reaping the fruits

Registered: 28/04/2014
Posts: 82
Loc: Leicestershire
Turned out the fuse blowing was the front wiper motor.
The battery drain is the aftermarket (quite old) radio being permanently live and sucking power

Top