Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey & James Northam - Funded by the Club for the benefit of all owners -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fiatcoupeclub.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
3 registered (Master_Mariner, OnlyItalian, Rosso), 96 Guests and 9 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
2,608 Registered Members
65 Forums
108,874 Topics
1,295,525 Posts

Most users ever online: 546 @ 30/08/2007 19:16
Top Posters
stan 32079
barnacle 31764
Theresa 22716
bockers 20994
pinin_prestatyn 19865
PeteP 18591
JimO 17908
Nigel 16870
Jim_Clennell 16223
Vickster 15915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1608981 - 04/10/2017 22:49 Engine mount issue
Dayno5 Offline
Discoverer

Registered: 15/03/2011
Posts: 30
Loc: cheshire
Just wondering if you can help...just in the middle of trying to replace the cambelt on my 20v turbo... removed the bolt from through the front n/s engine mount (near alternator) and the whole rubber is in pieces...
The only replacement i can find is :

http://www.ebay.co.uk/itm/Fiat-20v-Coupe-Vibra-Technics-RH-Engine-Mount-Fast-Road-FIA220M/222293090223?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2055119.m1438.l2649

Although it looks great i really dont want to spend this kind of money!
Does anyone know where i can buy a new cheaper one?
Or is it possible to replace the rubber as the metal part of the mount is all fine?
If so where can i buy these?
Thanks in advance for any help!!!

Top
#1608985 - 04/10/2017 23:10 Re: Engine mount issue [Re: Dayno5]
Edinburgh Online   content
Club member 225
Je suis un Coupé

Registered: 04/03/2007
Posts: 9960
Loc: Auld Reekie
Try Joe at FCSS
_________________________


So there, Photobucket...

Top
#1608986 - 04/10/2017 23:19 Re: Engine mount issue [Re: Dayno5]
patrickstar Offline
Club member 1139
Enjoying the ride

Registered: 05/01/2012
Posts: 577
Loc: Stockport
I'm in the middle of changing mine to vibra technics and the last one to do is the one you need so when I do mine Thurs or Fri if my old one is good your welcome to it.from what I can see it looks fine just cover the postage.

Top
#1608987 - 04/10/2017 23:20 Re: Engine mount issue [Re: Dayno5]
patrickstar Offline
Club member 1139
Enjoying the ride

Registered: 05/01/2012
Posts: 577
Loc: Stockport
It's the off side you mean on drivers side.

Top
#1608988 - 04/10/2017 23:47 Re: Engine mount issue [Re: Dayno5]
Dayno5 Offline
Discoverer

Registered: 15/03/2011
Posts: 30
Loc: cheshire
Yes sorry i meant o/s...
Yes that would be great id really appreciate that thanks!
Just let me know how you get on

Top
#1609051 - 06/10/2017 12:04 Re: Engine mount issue [Re: Dayno5]
patrickstar Offline
Club member 1139
Enjoying the ride

Registered: 05/01/2012
Posts: 577
Loc: Stockport
Sorry Dayno5 I've replaced mine today and this is it, same as yours.

click to enlarge

Top
#1609071 - 06/10/2017 20:14 Re: Engine mount issue [Re: Dayno5]
Dayno5 Offline
Discoverer

Registered: 15/03/2011
Posts: 30
Loc: cheshire
Its crazy mines exactly the same... the engine had dropped so the very bottom idler wouldnt even turn...the belt was just running over it!
Do you know if i can just buy the rubber center as the housing
is fine?

Top
#1609076 - 06/10/2017 21:34 Re: Engine mount issue [Re: Dayno5]
patrickstar Offline
Club member 1139
Enjoying the ride

Registered: 05/01/2012
Posts: 577
Loc: Stockport
You could buy a poly bushing liquid that you mix and pour and set you just have to make sure that your part that the bolt goes through is in the correct position.
Their are videos on you tube to show you how and links to the liquids you will need.

Top
#1609091 - 06/10/2017 23:24 Re: Engine mount issue [Re: Dayno5]
Dayno5 Offline
Discoverer

Registered: 15/03/2011
Posts: 30
Loc: cheshire
Thanks for the advice! Ive just ordered some, never tried it before but doesnt look to difficult (famous last words)

Top
#1609469 - 12/10/2017 16:29 Re: Engine mount issue [Re: Dayno5]
Henklia Offline
On a journey

Registered: 31/08/2012
Posts: 179
Loc: Netherlands
Do these fit?
http://www.strongflex.eu/en/1165-coupe-93-00

Scroll to bottom of the page

Henk

Top
#1609490 - 12/10/2017 21:26 Re: Engine mount issue [Re: Dayno5]
patrickstar Offline
Club member 1139
Enjoying the ride

Registered: 05/01/2012
Posts: 577
Loc: Stockport
Not for the mount you need they are for front arb , wishbones, and top engine arm.

Top
#1609680 - 15/10/2017 21:31 Re: Engine mount issue [Re: Dayno5]
Dayno5 Offline
Discoverer

Registered: 15/03/2011
Posts: 30
Loc: cheshire
The third from bottom does look like the right shape!
I actually bought a poly bushing liquid kit and made my own... I was pretty happy how it turned out very solid and only cost about £8 to make it.
I would definitely do it again

Top