Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey & James Northam - Funded by the Club for the benefit of all owners -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fiatcoupeclub.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
5 registered (Morrison, avtokrator, ali_hire, Master_Mariner, OnlyItalian), 74 Guests and 8 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
2,608 Registered Members
65 Forums
108,874 Topics
1,295,525 Posts

Most users ever online: 546 @ 30/08/2007 19:16
Top Posters
stan 32079
barnacle 31764
Theresa 22716
bockers 20994
pinin_prestatyn 19865
PeteP 18591
JimO 17908
Nigel 16870
Jim_Clennell 16223
Vickster 15915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1612561 - 04/12/2017 14:49 Post service tick over issue when cold
BBR Offline
Club member 1435 - Membership
My life on the forum

Registered: 15/05/2011
Posts: 1626
Loc: Hemel of the Hempstead
I recently serviced my 16vna

New plugs, leads, cap, rotor arm, oil, air and oil filters, coolant

Plus I removed thermostat from housing and replaced with inline option
Plus I installed a new induction hose just prior to the ICV as the previous one was split

Now the car doesn't idle when cold - any ideas
_________________________
16v NA Blitz Blue

Top
#1612566 - 04/12/2017 15:42 Re: Post service tick over issue when cold [Re: BBR]
GrahamL Offline
I need some sleep

Registered: 17/12/2005
Posts: 3471
Loc: Pothole City
Air leak around the new hose or wrong plugs?

Sometimes plugs have the same basic ID number but there are different spark gap versions within that ID and if the supplier isn't aware of that you can get a non-standard gap version supplied. Maybe try the old ones back in it if you still have them and they were still working OK?

Don't really know enough about the 16v to advise anything further.

Top
#1612588 - 04/12/2017 18:54 Re: Post service tick over issue when cold [Re: BBR]
barnacle Offline
Club Member 18 - Membership Secretary
Forum Demigod

Registered: 17/12/2005
Posts: 31764
Loc: Hemel in the Hempstead
ICV died? The coil goes open circuit, the valve stays shut. Measure the coil resistance.

Meanwhile, temporary fix is to crank up the idle speed via the bypass bleed on the throttle body (big brass screw).
_________________________

Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!

Top
#1612594 - 04/12/2017 20:03 Re: Post service tick over issue when cold [Re: GrahamL]
BBR Offline
Club member 1435 - Membership
My life on the forum

Registered: 15/05/2011
Posts: 1626
Loc: Hemel of the Hempstead
Originally Posted By GrahamL
Air leak around the new hose or wrong plugs?

Sometimes plugs have the same basic ID number but there are different spark gap versions within that ID and if the supplier isn't aware of that you can get a non-standard gap version supplied. Maybe try the old ones back in it if you still have them and they were still working OK?

Don't really know enough about the 16v to advise anything further.


I will check the plugs Graham, just in case
_________________________
16v NA Blitz Blue

Top
#1612595 - 04/12/2017 20:05 Re: Post service tick over issue when cold [Re: barnacle]
BBR Offline
Club member 1435 - Membership
My life on the forum

Registered: 15/05/2011
Posts: 1626
Loc: Hemel of the Hempstead
Originally Posted By barnacle
ICV died? The coil goes open circuit, the valve stays shut. Measure the coil resistance.

Meanwhile, temporary fix is to crank up the idle speed via the bypass bleed on the throttle body (big brass screw).


Hmmm that would be a pain for the ICV to die during a service, how could that happen?
I will measure the resistance for sure... would anything show up in startrek?
Big brass screw will be found in meantime then, thanks Neil
_________________________
16v NA Blitz Blue

Top
#1612599 - 04/12/2017 20:24 Re: Post service tick over issue when cold [Re: BBR]
barnacle Offline
Club Member 18 - Membership Secretary
Forum Demigod

Registered: 17/12/2005
Posts: 31764
Loc: Hemel in the Hempstead
I think the ECU knows what the mark/space ratio driving the ICV is, but doesn't measure the thing. It seems to measure only input things, not outputs.

You will have had to take it off to get to the thermostat, I think, which might have caused an issue - but also, it might be something else entirely.

You know about making sure the tube from the manifold to the pressure sensor is neither blocked nor split? Doesn't usually stop it idling but can cause all sorts of woe...
_________________________

Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!

Top
#1612604 - 04/12/2017 20:32 Re: Post service tick over issue when cold [Re: BBR]
BBR Offline
Club member 1435 - Membership
My life on the forum

Registered: 15/05/2011
Posts: 1626
Loc: Hemel of the Hempstead
I can’t wait to get back in the garage again now, so much to do...
_________________________
16v NA Blitz Blue

Top
#1612631 - 05/12/2017 11:56 Re: Post service tick over issue when cold [Re: BBR]
Master_Mariner Online   content
Club member 583
Making a profit

Registered: 16/09/2007
Posts: 397
Loc: Freedom
"leads, cap, rotor arm,"

Hi BBR - old school hat on here...try swapping out the new rotor arm for the old-Or new cap for the old- or variations of both- just to eliminate them as causing the issue?

And fairly quick items to check..

Regards

MM

Top