Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey & James Northam - Funded by the Club for the benefit of all owners -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fiatcoupeclub.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
8 registered (Alan_K, Dazvr6, KrisA, DaveG, neil_r, 1 invisible), 61 Guests and 6 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
2,588 Registered Members
65 Forums
108,771 Topics
1,294,591 Posts

Most users ever online: 546 @ 30/08/2007 19:16
Top Posters
stan 32079
barnacle 31719
Theresa 22694
bockers 20993
pinin_prestatyn 19865
PeteP 18559
JimO 17908
Nigel 16844
Jim_Clennell 16212
Vickster 15915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1614306 - 10/01/2018 17:46 Help no engine cooling fan or interior fan
H_R Offline
Club member 1114
My life on the forum

Registered: 30/07/2012
Posts: 1593
Loc: Dark side of the Moon
Hi stuck on m25 no engine cooling fan or interior fan everything else seems to work checked all big fuses under engine passenger side none of them look heat damaged and all look ok not blown don’t have any test gear so stuck other than what to look for that feeds these it has air con

Appreciate any help cheers

Top
#1614307 - 10/01/2018 18:00 Re: Help no engine cooling fan or interior fan [Re: H_R]
Edinburgh Offline
Club member 225
Je suis un Coupé

Registered: 04/03/2007
Posts: 9922
Loc: Auld Reekie
Have you checked the two connectors connections behind the top of the rad, in the centre?


Edited by Edinburgh (10/01/2018 21:03)
Edit Reason: connections
_________________________


So there, Photobucket...

Top
#1614308 - 10/01/2018 18:10 Re: Help no engine cooling fan or interior fan [Re: Edinburgh]
H_R Offline
Club member 1114
My life on the forum

Registered: 30/07/2012
Posts: 1593
Loc: Dark side of the Moon
Do you mean on the resister they look ok but don’t have any test gear so struggling to confirm anything
Is there anything that relates the interior to engine fan?

Top
#1614310 - 10/01/2018 18:20 Re: Help no engine cooling fan or interior fan [Re: H_R]
H_R Offline
Club member 1114
My life on the forum

Registered: 30/07/2012
Posts: 1593
Loc: Dark side of the Moon
Have 12 volts on fan so Possibly neutral?

Top
#1614311 - 10/01/2018 18:30 Re: Help no engine cooling fan or interior fan [Re: H_R]
Gunzi Offline
Club Member 189
Forum is my life

Registered: 30/08/2007
Posts: 6481
Loc: Southsea
All fuses in the engine bay ok?

Top
#1614312 - 10/01/2018 18:46 Re: Help no engine cooling fan or interior fan [Re: H_R]
Edinburgh Offline
Club member 225
Je suis un Coupé

Registered: 04/03/2007
Posts: 9922
Loc: Auld Reekie
Originally Posted By H_R
Do you mean on the resister they look ok but don’t have any test gear so struggling to confirm anything
Is there anything that relates the interior to engine fan?


I meant the connectors which fit onto the small black unit at the back of the rad.....I've had one of mine drop off before
_________________________


So there, Photobucket...

Top
#1614313 - 10/01/2018 19:08 Re: Help no engine cooling fan or interior fan [Re: H_R]
GrahamL Offline
I need some sleep

Registered: 17/12/2005
Posts: 3444
Loc: Pothole City
There's nothing directly relating the interior fan to the radiator fans, unless you have major power failure and most other systems are down as well. The power for both does initially run back to the exposed (interior) and covered (radiator) fuses behind the battery though, so unless there's something obviously wrong around there it's probably just coincidence.

Check the big connectors at the front of the box on top of windscreen washer tank (and the exposed ground connector there), that's where the radiator fans are switched, without tools to remove the cover you won't be able to check the relay though.

Is the injection malfunction light on?

Top
#1614318 - 10/01/2018 21:39 Re: Help no engine cooling fan or interior fan [Re: H_R]
H_R Offline
Club member 1114
My life on the forum

Registered: 30/07/2012
Posts: 1593
Loc: Dark side of the Moon
Right AA bridged the relay under the ac cover on top of the washer bottle as you mentioned Graham, I have NO live or negative power issues to the fans everything as it should be
The issue is with the signals or supply to the actual relays that control everything
I have lost engine fan including when ac is turned on and interior fan, interior fan also does not turn on in defrost setting also rear demise does not come on in defrost setting but does if manually switched
Everything else works

I’m going to have a look at the weekend provided it’s dry

Thanks for the input above I was really stuck trying to check stuff as I was in my Sunday best and without any tools
Also the traffic was a hinderance as I could of probably made it without traffic

Never mind I will update in case it helps anybody else

Cheers Guys!!

Top
#1614320 - 10/01/2018 23:15 Re: Help no engine cooling fan or interior fan [Re: H_R]
ioksotot Online   content
Club Member: 29
Enjoying the ride

Registered: 27/06/2008
Posts: 647
Loc: Kingston-upon-Hull
Had something very similar to this last month, see my thread here. My problem was the climate ecu which lives in the passenger side footwell.

Top
#1614324 - 11/01/2018 00:48 Re: Help no engine cooling fan or interior fan [Re: H_R]
GrahamL Offline
I need some sleep

Registered: 17/12/2005
Posts: 3444
Loc: Pothole City
Did it work OK when they bridged the relay?

If so, could be just the relay is faulty, or the connections inside that box have failed.

You can DIY repair the box internals as shown here:

http://www.fiatcoupe.fr/entretien-Boitier-Clim.php

but probably easier to just replace it with a good used one. Also worth cleaning the relay pins and the socket in the box with a thin file.

As for the internal fan, could be the climate ECU if the rear screen heater is working manually but not from MAX DEF setting. But double check the fuse and holder in engine bay (exposed 30A) and the wipers fuse in main fuse box, I think the climate ECU also takes power on that circuit.

Top
#1614327 - 11/01/2018 06:53 Re: Help no engine cooling fan or interior fan [Re: H_R]
H_R Offline
Club member 1114
My life on the forum

Registered: 30/07/2012
Posts: 1593
Loc: Dark side of the Moon
The relay worked ok when bridged, was just glad to get home yesterday without an engine rebuild for something so trivial!

Next step is to see what’s missing the switched negative from the ecu or the positive supply!

Can somebody tell me how to get the ecu to put the fans on so I can test was it disconnect an engine or temperature sensor somewhere? If somebody could tell me which one and where it’s located that would be great!

Regarding the ac not working (not bringing fan on at low speed) I guess that’s to do with the whole climate control I did however have a light on the ac switch but I know this means nothing if empty but the ac was working in the morning I checked

I am going to treat these as two unrelated faults unless I can find anything relating them on the schematic diagram

Thanks for the info relating to the relay box I think that’s a good shout!

Just hoping for a dry weekend not enough daylight either side of work at the moment, luckily I don’t need to use my car it’s just a second/third car

Cheers!

Top
#1614371 - 11/01/2018 21:01 Re: Help no engine cooling fan or interior fan [Re: H_R]
Submariner Offline
Enjoying the ride

Registered: 20/12/2005
Posts: 1146
Loc: Kent
Sorry to butt in, I am interested in the above H_R as my interior fans have packed up and Max Def does not switch on rear demist (demist works via button) and I replaced the climate ECU and still it does not work.

I heard/felt a thud behind the dash trim by the dial when it stopped working so wonder if there is anything burnt out there, will have to have a look. Annoying especially in this weather!

Top
#1614382 - 12/01/2018 06:46 Re: Help no engine cooling fan or interior fan [Re: H_R]
H_R Offline
Club member 1114
My life on the forum

Registered: 30/07/2012
Posts: 1593
Loc: Dark side of the Moon
Hi I will update if I manage to solve this also if you find anything could you let me know too
The plan is too have a look Saturday weather pending
I have some of the schematic drawings but cannot see them (too small)
So hoping to zoom in on the photocopier at work to make life a bit easier!

Top
#1614432 - 13/01/2018 14:42 Re: Help no engine cooling fan or interior fan [Re: H_R]
H_R Offline
Club member 1114
My life on the forum

Registered: 30/07/2012
Posts: 1593
Loc: Dark side of the Moon
Ok started with radiator cooling circuit checked continuity all the way through power circuits and to the ecu everything ok
Removed thermostat sensor car wouldn’t start
Reconnected and started then removed sensor hey presto fans come on!
So it all seems to be working

Did it just run hotter than usual due to no heat dissipation into cab as all motorised vents were closed and no interior fan????
Was it just coupe paranoia! As the gauge was reading warmer than it usually gets to and I didn’t give it any opportunity to be a catastrophic failure ??

Only thing left to do is take it for a drive and test it out!


Right onto interior fan circuit removed and checked fan direct to battery all ok
Checked power at fan plug 12 volts checked power at plug when plugged into fan, instant volt drop, ok poor connection in power circuit somewhere checked fuse all ok
Something made me check a different circuit which I assumed was the fuel pump mod? Turned out to be the fuse in question overheated with one side scorched from arcing!

It has now jogged my memory it was damaged when it went for a respray so I replaced with a generic weatherproof fuse holder, so now I’m stumped as to what the other fuse is?
Anyway problem solved all working inside now

Question, how many fuses should there be as I seem to have 3 that would of been original?
1 radiator fan large covered fuse
2 interior fan
3 ??

Cheers

Top
#1614483 - 14/01/2018 18:49 Re: Help no engine cooling fan or interior fan [Re: H_R]
Submariner Offline
Enjoying the ride

Registered: 20/12/2005
Posts: 1146
Loc: Kent
What was the location of your mystery fuse?

Top
#1614484 - 14/01/2018 19:49 Re: Help no engine cooling fan or interior fan [Re: H_R]
H_R Offline
Club member 1114
My life on the forum

Registered: 30/07/2012
Posts: 1593
Loc: Dark side of the Moon
Sorry no mystery it’s the block of three fuses by the suspension turret!
The only mystery was I forgot I had repaired the fuse holder which is a non standard holder so didn’t think to check it
I have added an extra fuse for the fuel pump mod that looks like a standard fan fuse holder so I still have three fuses clipped together that look factory oem then the repaired fuse tucked below it
So four in total one of which is the fuel pump mod

When you checked yours did you have 12 volts at the fan plug with it plugged in?
After my issue it would seem your symptoms are similar and mine was a poor connection still showing 12 volts unplugged but as soon as any load was put on the circuit the volt drops to zero hence checking it whilst plugged in
Yours does sound like a power issue
Any more questions I’m happy to help

Top