Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey & James Northam - Funded by the Club for the benefit of all owners -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fiatcoupeclub.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
4 registered (Edinburgh, Alan_K, DaveG, 1 invisible), 68 Guests and 6 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
2,588 Registered Members
65 Forums
108,756 Topics
1,294,527 Posts

Most users ever online: 546 @ 30/08/2007 19:16
Top Posters
stan 32079
barnacle 31718
Theresa 22690
bockers 20993
pinin_prestatyn 19862
PeteP 18558
JimO 17908
Nigel 16843
Jim_Clennell 16211
Vickster 15915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1616765 - 02/03/2018 20:19 Leftside front indicator light dont work.
jugra Offline
Newbie

Registered: 24/10/2016
Posts: 4
Loc: Norway
Hello. First time on the forum. Front indicator light is not working. The blinker on the side and in the back is working. It will not work with the hazardbutton. The bulb is new ofcourse.

Any ideas?

Best regards from Norway

Top
#1616788 - 03/03/2018 07:08 Re: Leftside front indicator light dont work. [Re: jugra]
barnacle Offline
Club Member 18 - Membership Secretary
Forum Demigod

Registered: 17/12/2005
Posts: 31718
Loc: Hemel in the Hempstead
Even with a new bulb, check it again, and then check the holder for corroded contacts. Then the connector to the wiring loom.

If the other indicators on that side are working, then it's not the switch, fuse, or controller; there's a single output to everything on that side.
_________________________

Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!

Top
#1616792 - 03/03/2018 09:00 Re: Leftside front indicator light dont work. [Re: jugra]
rayzer82 Offline
On a journey

Registered: 21/01/2010
Posts: 168
Loc: basingstoke, england
Checked the bulbs not a damaged one? Could of been box damaged or in transit?


Edited by rayzer82 (03/03/2018 09:01)

Top
#1616795 - 03/03/2018 10:26 Re: Leftside front indicator light dont work. [Re: jugra]
jugra Offline
Newbie

Registered: 24/10/2016
Posts: 4
Loc: Norway
Thank you for response! I will check again tomorrow when i go to the garage. And my foglights in the front is dead , so have to fix that too.

I did buy this car 2 years ago, and have done a lot of work on it, so this is the only thing remaining.

I look forward to drive the car, actualy i have never driven it before!!!

Top
#1617168 - 11/03/2018 12:48 Re: Leftside front indicator light dont work. [Re: jugra]
jugra Offline
Newbie

Registered: 24/10/2016
Posts: 4
Loc: Norway
Thank you for response. I found the error. Its was me taking the wrong connector. The connector to A/C and lights is almost identical i found out. With the correct connector everything is working. Thanks

Top