Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey & James Northam - Funded by the Club for the benefit of all owners -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fiatcoupeclub.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
4 registered (Edinburgh, Alan_K, DaveG, 1 invisible), 68 Guests and 6 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
2,588 Registered Members
65 Forums
108,756 Topics
1,294,527 Posts

Most users ever online: 546 @ 30/08/2007 19:16
Top Posters
stan 32079
barnacle 31718
Theresa 22690
bockers 20993
pinin_prestatyn 19862
PeteP 18558
JimO 17908
Nigel 16843
Jim_Clennell 16211
Vickster 15915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1616632 - 28/02/2018 16:43 Issue with Fiat Coupe 2.0 16V Engine
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
Issue with Fiat Coupe 2.0 16V
It is very difficult to start the car, once the engine is on, it can't rev and starts loosing power.
I have completely renovated the engine, the compression is fine,
- the engagement was checked many times and is also fine
- main parts that have been changed:
Fuel Pump
Furl Regulator
Distributor
Wiring Spark
Spark
Igntion Coil
MAP sensor
IAT senor
Tmepretarure sensor (injection)
Lamba Sonda
HALL sensor on Crankshaft
Clean Injectors
i tried using 3 different ECUs and there's no change with any of them
I've tracked the installation from the ECU to each Sensor and everything is fine.
Clip Run Engine = https://www.youtube.com/watch?v=kxl1gPA23XM&feature=youtu.be

Top
#1616644 - 28/02/2018 20:51 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
barnacle Offline
Club Member 18 - Membership Secretary
Forum Demigod

Registered: 17/12/2005
Posts: 31718
Loc: Hemel in the Hempstead
This is a very silly suggestion: have you put the fuel feed and return connectors back in the right place? They fit both ways...
_________________________

Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!

Top
#1616665 - 01/03/2018 09:50 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
yes, they are in the right place
Also, I forgot to mention that the car has inlet manifold kappa turbo and the balance shafts have been removed

Top
#1616820 - 04/03/2018 00:24 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
SVC Offline
Reaping the fruits

Registered: 22/01/2018
Posts: 55
Loc: Teresopolis
Since you overhauled the engine, check all engine and electronics ground straps if they are tight, or a forgotten disconnected one and also the battery negative cable.

Seems to me, looking at the video, that there is a noise entering the ECU.

That engine issue is so erratic to be a single component problem.
_________________________
--> My YouTube Channel

Top
#1616825 - 04/03/2018 09:10 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: SVC]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
Originally Posted By SVC
Since you overhauled the engine, check all engine and electronics ground straps if they are tight, or a forgotten disconnected one and also the battery negative cable.

Seems to me, looking at the video, that there is a noise entering the ECU.

That engine issue is so erratic to be a single component problem.

every Ground is Checked
i tried using 3 different ECUs and there's no change with any of them
i change the TPS - the same

Top
#1616919 - 05/03/2018 17:00 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
SVC Offline
Reaping the fruits

Registered: 22/01/2018
Posts: 55
Loc: Teresopolis
The power module of the ignition coil was changed too?
_________________________
--> My YouTube Channel

Top
#1616941 - 05/03/2018 22:59 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
kj16v Offline
My life on the forum

Registered: 12/02/2008
Posts: 1702
Loc: London
Sounds silly but you got the inlet cam on the inlet and exhaust cam on the exhaust?

I know it's stupidly obvious but just thought I'd mention anyway. It has happened before!

Top
#1617042 - 07/03/2018 12:05 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
SVC = The power module of the ignition coil is change too
kj16v= I'm not sure they are put in the right way actually, I'll check that, thanks for the advice!

Top
#1617046 - 07/03/2018 12:48 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
You can't actually switch the places of the cam inlet and cam outlet since the cam outlet has connection to the distributor

Top
#1617260 - 13/03/2018 12:19 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
kj16v Offline
My life on the forum

Registered: 12/02/2008
Posts: 1702
Loc: London
Originally Posted By Pawel
You can't actually switch the places of the cam inlet and cam outlet since the cam outlet has connection to the distributor


Sorry I should have said the cam PULLEYS! Mixing those up is very possible!

Speaking of cams, check the timing marks on the cam and crank pulleys all line up too.


Edited by kj16v (13/03/2018 12:20)

Top
#1617978 - 28/03/2018 23:55 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
SVC Offline
Reaping the fruits

Registered: 22/01/2018
Posts: 55
Loc: Teresopolis
Hi Pawel, any luck?

The engine looks also incredible lean.
Check the voltage variation over the lambda sensor pin under acceleration.

Another thing, is the fuel pressure okay?
_________________________
--> My YouTube Channel

Top
#1618080 - 31/03/2018 17:03 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
cam PULLEYS it`s ok
timing marks it`s ok
fuel pressure it`s ok
lambda sensor it`s 3 new

Top
#1618083 - 31/03/2018 18:44 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
G_Man Offline
Club member 1656
Enjoying the ride

Registered: 16/03/2006
Posts: 707
Loc: Warrington
Pawel - can't help you on your problem frown but SVC I'have checked your YouTube channel - much respect mate.. thumb


Edited by G_Man (31/03/2018 18:46)

Top
#1618236 - 03/04/2018 22:12 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
SVC Offline
Reaping the fruits

Registered: 22/01/2018
Posts: 55
Loc: Teresopolis
Pawel, understood that Lambda sensor is new. But did you measure the voltage entering the ECU? Is it oscillating between 0 and 1 volt on idle?

G_Man, thank you! Very appreciated your comment.
_________________________
--> My YouTube Channel

Top
#1618246 - 04/04/2018 00:58 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
GrahamL Offline
I need some sleep

Registered: 17/12/2005
Posts: 3442
Loc: Pothole City
I know nothing about the 16v's but I see the spark plug leads are long enough to allow connection to the wrong plugs, could that be it?

If you still have some of the old parts left that were still working OK I'd try switching bits back in just in case there's a problem with one or more of the new parts or the wrong part was supplied.

Top
#1619037 - 16/04/2018 18:03 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
SVC - the lambda sonda was changed 3 times and the car diagnostic live data showed 0-1 an year ago. Since then it's been impossible to connect it to the diagnostic tool for some unknown reason.

Top
#1619038 - 16/04/2018 18:03 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
GrahamL - yes all wires are correctly connected and in the right place

Top
#1619043 - 16/04/2018 19:43 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
SVC Offline
Reaping the fruits

Registered: 22/01/2018
Posts: 55
Loc: Teresopolis
Try to turn the TPS few degrees CCW and see what happens.
_________________________
--> My YouTube Channel

Top
#1619087 - 17/04/2018 16:12 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
SVC = I tried to adjust the tps with 5 degrees advance an year ago but nothing changed

Top
#1619104 - 18/04/2018 06:09 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
barnacle Offline
Club Member 18 - Membership Secretary
Forum Demigod

Registered: 17/12/2005
Posts: 31718
Loc: Hemel in the Hempstead
Have you tried asking the ECU if it has reported any problems? http://www.nailed-barnacle.co.uk/coupe/startrek/startrek.html
_________________________

Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!

Top
#1619189 - 20/04/2018 20:57 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
barnacle = I've never succeeded connecting it with Startreck 409. It used to connect with IAWScan2 for some time giving the same lambda sonda error every time. Now it can't connect any longer

Top
#1619190 - 20/04/2018 20:58 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
every time even after I had it replaced with a new one. *

Top
#1619193 - 20/04/2018 21:38 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
barnacle Offline
Club Member 18 - Membership Secretary
Forum Demigod

Registered: 17/12/2005
Posts: 31718
Loc: Hemel in the Hempstead
Hmmm. I don't have a solution, except to observe that perhaps the 409 adaptors are being sold recently with a different chipset that can't handle the odd baud rate that Marelli used. frown
_________________________

Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!

Top
#1619251 - 22/04/2018 00:05 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
SVC Offline
Reaping the fruits

Registered: 22/01/2018
Posts: 55
Loc: Teresopolis
Something electrical is not connected correctly, like I said before, a missing ground or maybe, just maybe, the wires of the crank position sensor inverted.
This sensor, incredible to imagine, DO have polarity.
_________________________
--> My YouTube Channel

Top
#1619277 - 22/04/2018 16:30 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
Pawel Offline
Newbie

Registered: 22/03/2013
Posts: 12
Loc: Widin Bulgaria
I've tracked the installation from the ECU to each Sensor and everything is fine.
Chek again tomorrow
thanks SVC

Top
#1619284 - 22/04/2018 20:24 Re: Issue with Fiat Coupe 2.0 16V Engine [Re: Pawel]
GrahamL Offline
I need some sleep

Registered: 17/12/2005
Posts: 3442
Loc: Pothole City
In the video when it misfires badly at 8 seconds there's a puff of smoke from the dipstick tube... maybe that's a clue? Blow by or crankcase ventilation issue or something? Have you tried it with the crankcase breather pipe disconnected and blocked on the intake side? Maybe it's pushing a horrible smokey mixture back into the intake?

Top