Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
4 registered members (Yann, alex1982, Honza, 1 invisible), 61 guests, and 1 spider.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics109,651
Posts1,303,045
Members2,760
Most Online546
Aug 30th, 2007
Top Posters(All Time)
stan 32,098
barnacle 32,061
Theresa 22,814
bockers 21,009
PeteP 18,957
JimO 17,908
Nigel 17,039
Jim_Clennell 16,304
Vickster 15,915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
16v n/a missfire/fluffy #1621250
02/06/2018 07:47
02/06/2018 07:47
Joined: Apr 2014
Posts: 60
norwich
A
acc67 Offline OP
Reaping the fruits
acc67  Offline OP
Reaping the fruits
A

Joined: Apr 2014
Posts: 60
norwich
Started my 16v up this morning drove 2 miles and switched it off, then was really reluctant to start. Once it did it was missing but off idle under load. No warning light, popped the bonnet and checked plug leads, coil connection and distrubutor connection all ok. Spark plugs changed 2 weeks ago for the same problem.Only seems to do it if left a few days. Now it's decided it's going to behave itself which is great but not when your trying to find the fault. Any suggestions woukd be good.

Re: 16v n/a missfire/fluffy [Re: acc67] #1621412
05/06/2018 20:41
05/06/2018 20:41
Joined: Mar 2006
Posts: 798
Warrington
G_Man Offline
Club member 1656
G_Man  Offline
Club member 1656
Enjoying the ride

Joined: Mar 2006
Posts: 798
Warrington
I had similar symptoms with my MGF when the fuel pump was on it's way out although I'm sure it wouldn't last over a 2 week period. Faulty sensor somewhere?

Re: 16v n/a missfire/fluffy [Re: acc67] #1621473
06/06/2018 18:24
06/06/2018 18:24
Joined: Dec 2005
Posts: 32,061
Hemel in the Hempstead
barnacle Offline
Club Member 18 - Minister without Portfolio
barnacle  Offline
Club Member 18 - Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,061
Hemel in the Hempstead
Check for breakdown in the plug cable insulation under the cover, or where the rubber plug holds the bundle in the end of the engine.



Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!
Re: 16v n/a missfire/fluffy [Re: acc67] #1621481
06/06/2018 19:33
06/06/2018 19:33
Joined: Apr 2014
Posts: 60
norwich
A
acc67 Offline OP
Reaping the fruits
acc67  Offline OP
Reaping the fruits
A

Joined: Apr 2014
Posts: 60
norwich
Thanks will have a look at the weekend, it behaved itself on a 80 mile run today. Think it's just being Italian!!

Re: 16v n/a missfire/fluffy [Re: acc67] #1621517
07/06/2018 17:06
07/06/2018 17:06
Joined: Dec 2005
Posts: 32,061
Hemel in the Hempstead
barnacle Offline
Club Member 18 - Minister without Portfolio
barnacle  Offline
Club Member 18 - Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,061
Hemel in the Hempstead
Looking in the dark for sparks can be helpful.



Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!
Re: 16v n/a missfire/fluffy [Re: acc67] #1624615
02/09/2018 18:39
02/09/2018 18:39
Joined: Apr 2014
Posts: 60
norwich
A
acc67 Offline OP
Reaping the fruits
acc67  Offline OP
Reaping the fruits
A

Joined: Apr 2014
Posts: 60
norwich
Eventually it played up again a couple of weeks a go. Hot and after turning it off for approx 15 mins it Popped banged and didn't want to start but it did just.
Thinking of hot heat soak I decided to change the pick up inside the distributor, which so far seems to have worked.

Last edited by acc67; 02/09/2018 18:40.

Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.2 Page Time: 0.031s Queries: 14 (0.012s) Memory: 0.7655 MB (Peak: 0.8219 MB) Data Comp: Off Server Time: 2019-03-20 19:10:10 UTC