Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
0 registered members (), 87 guests, and 1 spider.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics109,673
Posts1,303,251
Members2,762
Most Online546
Aug 30th, 2007
Top Posters(All Time)
stan 32,098
barnacle 32,076
Theresa 22,815
bockers 21,009
PeteP 18,969
JimO 17,908
Nigel 17,043
Jim_Clennell 16,308
Vickster 15,915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
Fri 13th MOT woes #1618884
13/04/2018 19:22
13/04/2018 19:22
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
So my welding passed, the brakes passed
BUT
the tester found a broken spring on the front near side, which would have been missed on the previous test as it has not been driven. One bolt left too extract and I can get a replacement strut and spring installed, but I cannot get the bolt out for love nor money.
PLUS
Bloody emissions fail again, just dunno what to do to get the CO emissions down


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1618906
14/04/2018 09:36
14/04/2018 09:36
Joined: Dec 2005
Posts: 3,080
S. Wales. Way beyond my means
Gripped Offline
I need some sleep
Gripped  Offline
I need some sleep

Joined: Dec 2005
Posts: 3,080
S. Wales. Way beyond my means
Sorry to hear it. Hope you get the bolt out. Have you tried a bit of heat or some wd40/plusgas?

As for CO, could this indicate a boost leak ?
Incomplete combustion and running rich. Possible lambda sensor issues?
Exhaust leak (pre-lambda) - that could cause ECU to add too much fuel and increase emissions.
Google search suggested MAF sensor also.

Good luck


[Linked Image]
Re: Fri 13th MOT woes [Re: BBR] #1618920
14/04/2018 13:31
14/04/2018 13:31
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
Thanks Gripped.

My list to check and clean at the moment includes:
ICV,
lambda sensor (most likely as on startrek it showed an error),
exhaust leak,
MAF sensor.

It is my 16vna which failed so thankfully not a boost leak wink


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1618937
14/04/2018 19:15
14/04/2018 19:15
Joined: Dec 2005
Posts: 3,080
S. Wales. Way beyond my means
Gripped Offline
I need some sleep
Gripped  Offline
I need some sleep

Joined: Dec 2005
Posts: 3,080
S. Wales. Way beyond my means
Aha, hopefully a new lambda will sort it then.

I'd expect it to run rough if the MAF was knackered, so hopefully not that.

fingers crossed thumb


[Linked Image]
Re: Fri 13th MOT woes [Re: BBR] #1618939
14/04/2018 20:16
14/04/2018 20:16
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
It’s going have to wait until next week to be fixed.
And I’ve gotta get broken spring swapped out.
Thanks again


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1618946
14/04/2018 21:50
14/04/2018 21:50
Joined: Sep 2008
Posts: 4,436
J
JKD Offline
Forum is my job
JKD  Offline
Forum is my job
J

Joined: Sep 2008
Posts: 4,436
BBR what welding did you do on your Coop?

Re: Fri 13th MOT woes [Re: BBR] #1618954
15/04/2018 04:56
15/04/2018 04:56
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
I cut out an area underneath the passenger seat close to the seat mount which failed the MOT and welded in a plate.


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1620959
26/05/2018 14:51
26/05/2018 14:51
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
Please help - What on earth do I change or clean on a 16v NA to get it through the CO emissions test??????

I have put on a new CAT, New Lambda, new Radiator, New thermostat

I have removed, checked and cleaned EVERY pipe up to the throttle body

I have run startrek and temps seem 'good'

Running out of ideas frown


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1620965
26/05/2018 16:10
26/05/2018 16:10
Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
barnacle Offline
Club Member 18 - Minister without Portfolio
barnacle  Offline
Club Member 18 - Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
Checked the pipe from the map sensor to the manifold? Or indeed the map sensor itself?

(Sorry I was a bit slow this morning - still asleep smile )



Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!
Re: Fri 13th MOT woes [Re: BBR] #1620967
26/05/2018 16:40
26/05/2018 16:40
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
It was good seeing you this morning Neil
I can’t see any sensor between air box and throttle body
There is a fat plastic tube but it’s hollow and nothing electrical attached
Now I am being slow

I have read some more posts of yours Neil and I know where to look for the map sensor now and the pipe to the plenum which should not be split and also clear so will check that out too.

Last edited by BBR; 26/05/2018 20:28.

16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1620988
27/05/2018 08:24
27/05/2018 08:24
Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
barnacle Offline
Club Member 18 - Minister without Portfolio
barnacle  Offline
Club Member 18 - Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
Come round and have a look at mine if you want, at least I can point at the places to check.



Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!
Re: Fri 13th MOT woes [Re: BBR] #1620994
27/05/2018 12:42
27/05/2018 12:42
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
Thanks Neil
I may well pop round one evening


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1621305
03/06/2018 17:03
03/06/2018 17:03
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
So I finally took the plenum bolts out as it is impossible to get to the other end of the map sensor pipe from any direction unless you are a toddler of course.

The pipe is NOT split and sit flows through perfectly.

The throttle assembly, bleed valve, air sensor thingy attached to throttle assembly and just post aitbox, Weber carb, all contacts and pipes cleaned thoroughly.

Injector light still on, but car sounds great although convinced it’s still overfuelling as smells rich if that is even a sign...


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1621314
03/06/2018 19:17
03/06/2018 19:17
Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
barnacle Offline
Club Member 18 - Minister without Portfolio
barnacle  Offline
Club Member 18 - Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
If the light's on, let startrek find out what the ECU thinks is poorly.



Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!
Re: Fri 13th MOT woes [Re: BBR] #1621317
03/06/2018 21:11
03/06/2018 21:11
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
It “lies” though, it says lambda and cam sensor but lambda new and cam sensor checked out
Same output of errors every time as above


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1621318
03/06/2018 21:12
03/06/2018 21:12
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
Can try again though just in case


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1621333
04/06/2018 08:56
04/06/2018 08:56
Joined: Sep 2009
Posts: 4,631
ation
S
szkom Offline
Forum is my job
szkom  Offline
Forum is my job
S

Joined: Sep 2009
Posts: 4,631
ation
Originally Posted By BBR
It “lies” though, it says lambda and cam sensor but lambda new and cam sensor checked out
Same output of errors every time as above


Does it say they're broken, or that there's a value that isn't expected?

Re: Fri 13th MOT woes [Re: BBR] #1621336
04/06/2018 11:45
04/06/2018 11:45
Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
barnacle Offline
Club Member 18 - Minister without Portfolio
barnacle  Offline
Club Member 18 - Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
lambda is just a pass/fail.

Try the console version, if you haven't already?



Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!
Re: Fri 13th MOT woes [Re: BBR] #1621343
04/06/2018 14:18
04/06/2018 14:18
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
Scenario was ...

start startrek
lambda pass
wait seconds
lambda fail

replace lambda sensor
start startrek
lambda pass
wait seconds
lambda fail

I will try it again and post pictures again
I still get the cam sensor error too

And the injector light is still on

Last edited by BBR; 04/06/2018 14:20. Reason: clarification

16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1621352
04/06/2018 17:14
04/06/2018 17:14
Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
barnacle Offline
Club Member 18 - Minister without Portfolio
barnacle  Offline
Club Member 18 - Minister without Portfolio
Forum Demigod

Joined: Dec 2005
Posts: 32,076
Hemel in the Hempstead
I can't remember whether the code (hey, it's ten years since I wrote it!) reads the error codes as often as the status data. I have an idea it does it only every five seconds or so.



Don't get no respect! Coupe Fiat 1994-2000 - an owner's guide <-- clicky!
Re: Fri 13th MOT woes [Re: BBR] #1621366
04/06/2018 20:36
04/06/2018 20:36
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
That makes sense. Going to make sure fdti drivers installed and using new cable next attempt too


16v (Blitz)
Re: Fri 13th MOT woes [Re: BBR] #1622714
07/07/2018 08:54
07/07/2018 08:54
Joined: Dec 2005
Posts: 18,969
Aldershot
PeteP Offline
Ex Presidente and Treasurer
PeteP  Offline
Ex Presidente and Treasurer
Forum veteran

Joined: Dec 2005
Posts: 18,969
Aldershot
A bit of a thread resurrection Rich. I don't know if you have resolved the problem.

When I put mine through its MOT yesterday the emissions, particularly CO, were a bit higher than they were 14 months and just 600 miles previously.

Thinking about it, the petrol in the tank probably dated back to September last year as I hadn't used the car since then. I wonder if old petrol could be your problem?


16VT and X1/9 1500
Re: Fri 13th MOT woes [Re: BBR] #1622718
07/07/2018 11:13
07/07/2018 11:13
Joined: May 2011
Posts: 1,957
Caston, Norfolk
BBR Offline OP
Membership secretary
BBR  Offline OP
Membership secretary
My life on the forum

Joined: May 2011
Posts: 1,957
Caston, Norfolk
I gave the tester a score in the end and it flew through the emissions.

The car has been driven lots so it doesn't have old fuel in it.

Latest theory is the map sensor itself is bust, but that's very rare.

Nice cheap part though so I will try it and get my friendly mot guy to redo emissions until we find what's actually causing it.

Thanks Pete


16v (Blitz)

Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.2 Page Time: 0.020s Queries: 14 (0.007s) Memory: 0.8528 MB (Peak: 1.0142 MB) Data Comp: Off Server Time: 2019-03-26 01:51:35 UTC