Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey & James Northam - Funded by the Club for the benefit of all owners -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fiatcoupeclub.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
3 registered (Richie007, 2 invisible), 55 Guests and 6 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
2,607 Registered Members
65 Forums
108,872 Topics
1,295,494 Posts

Most users ever online: 546 @ 30/08/2007 19:16
Top Posters
stan 32079
barnacle 31764
Theresa 22716
bockers 20994
pinin_prestatyn 19865
PeteP 18589
JimO 17908
Nigel 16870
Jim_Clennell 16223
Vickster 15915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1622898 - 12/07/2018 12:45 Injector symbol on.
magooagain Offline
Club member 259
Forum is my life

Registered: 22/10/2008
Posts: 6410
Loc: ked
Started up my 20vt yesterday and all was well. I moved it about a few times during the morning with no issues.

While I had the bonnet up and the engine running I was blowing the dust out of the engine bay with my airline gun,the engine blipped a bit.

This morning after some brake pad cleaning etc I went to start it and it fired up and died straight after reaching cold temp revs. Tried another couple of time and just the same.
I unpluged the Maf and it ticked over fine but with injector light on constant.

I have now cleaned the Maf and the icv.
The car is running fine now but with the injector light on constant.

How can I get the light off and why is it on still?

I have disconnects the battery for some time but still the same.

Thanks in advance.


Edited by magooagain (12/07/2018 12:47)
_________________________

Waiting for forum photo hosting!

Top
#1622900 - 12/07/2018 13:07 Re: Injector symbol on. [Re: magooagain]
GrahamL Offline
I need some sleep

Registered: 17/12/2005
Posts: 3471
Loc: Pothole City
Disconnecting the battery will reset the error code in the ECU, so if the light is coming on then the problem is still present and is immediately re-activating the injector light. Best to get the error code read to find the exact source of the problem.

Top
#1622901 - 12/07/2018 13:08 Re: Injector symbol on. [Re: magooagain]
Master_Mariner Offline
Club member 583
Making a profit

Registered: 16/09/2007
Posts: 395
Loc: Freedom
Have you got the ability to get the codes read?

Light shows when injector dies / electrical fault I believe. I wonder if you have nudged/dislodged something while using the air gun-can't be coincidence?

Codes may point the way if there is no obvious wiring issue.

Bad luck if its not connected to your being in the engine bay at the time...coupe's don't like being mended!

Regards

MM

Top
#1622902 - 12/07/2018 13:09 Re: Injector symbol on. [Re: magooagain]
Master_Mariner Offline
Club member 583
Making a profit

Registered: 16/09/2007
Posts: 395
Loc: Freedom
Darn Graham beat me to it as I was typing :-)

Top
#1622904 - 12/07/2018 13:26 Re: Injector symbol on. [Re: magooagain]
magooagain Offline
Club member 259
Forum is my life

Registered: 22/10/2008
Posts: 6410
Loc: ked
Ok I thought I would run the engine up to temps. While I was doing that I gave the Maf plug a wiggle and it stalled the engine.
I had this some time ago and re taped up the plug after cleaning and checking.
Anyway I restarted the car and continued to run it up to temps,minutes later I got interrupted by a neighbour and had to switch the engine off.

5 mins later I've started it and the injector light blipped off and then back on, then it went off completely.

Everything back to normal!
_________________________

Waiting for forum photo hosting!

Top
#1622905 - 12/07/2018 13:50 Re: Injector symbol on. [Re: magooagain]
Master_Mariner Offline
Club member 583
Making a profit

Registered: 16/09/2007
Posts: 395
Loc: Freedom
Originally Posted By magooagain

Everything back to normal!



Good news - it clearly needs some electrical repair/renewing of the connector to make sure its back to 100%!

Glad you found the culprit!

MM

Top
#1622906 - 12/07/2018 14:09 Re: Injector symbol on. [Re: magooagain]
magooagain Offline
Club member 259
Forum is my life

Registered: 22/10/2008
Posts: 6410
Loc: ked
Thanks for the quick replies fella's .

Hopefully ok for a track day tomorrow .
_________________________

Waiting for forum photo hosting!

Top