Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey & James Northam - Funded by the Club for the benefit of all owners -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fiatcoupeclub.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
6 registered (mattcooke, MarioCirillo, Ballypete, Lappers, 2 invisible), 57 Guests and 9 Spiders online.
Key: Admin, Global Mod, Mod
Forum Stats
2,624 Registered Members
65 Forums
108,955 Topics
1,296,405 Posts

Most users ever online: 546 @ 30/08/2007 19:16
Top Posters
stan 32079
barnacle 31807
Theresa 22738
bockers 20996
pinin_prestatyn 19870
PeteP 18621
JimO 17908
Nigel 16896
Jim_Clennell 16229
Vickster 15915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1623742 - 08/08/2018 17:50 Alfa GT JTDM 1.9 Power Loss
skinflint Offline
I need some sleep

Registered: 07/02/2007
Posts: 3164
Loc: West Berks
The Alfa's up to about 170k now and has just lost most of its power. It starts and idles but stutters under load and won't rev happily beyond 2000 rpm.

The engine light isn't on although I haven't scanned for fault codes yet. It has felt reluctant to pick up boost initially over recent months but that goes after a couple of minutes usually.

There are no unusual noises, but I can't hear the turbo.

A quick web search seems to turn up turbo, EGR stuck open, I I thought fuel pump possibly but that doesn't seem to come up.

Sorry to be asking on the wrong forum but I know a few people on here are running the 1.9 JTD lump in various cars. Does anyone have any ideas / similar experiences with the JTD?



On a more relevant topic the Coupe has come on well recently. I decided to change the alternator and that turned into a project that involved new exhaust manifold, new cambelt, new rear exhaust, some painting of things like heat shields, and a bit of a go at the Eiffel towers at the front, but it is all back together ready to fail an MOT so hopefully it won't be long before I can come along to a meet. click to enlarge

Top
#1623743 - 08/08/2018 18:04 Re: Alfa GT JTDM 1.9 Power Loss [Re: skinflint]
DaveG Offline
Club member 311
Forum is my life

Registered: 16/12/2005
Posts: 6818
Loc: Lightwater, Surrey, UK
Hey Peter, we've not seen you around for a while?

Check the boost hoses, sounds similar to a problem on wifey's old Volvo TD, think that was also accompanied by copious amounts of black smoke (which you didn't mention) but worth a look, they always seem to split out of view...

As for the Coupe, well done, doing lots more than is strictly necessary is what I'm doing to the Porto 20vt (rear brakes failed MOT, now turning into a mini rear suspension overhaul, as well as the brakes)
_________________________
2000 Pearl White Plus & 1996 Portofino 20vt
1985 & 2016 2017 Fiat 124 Spider + XF Sportbrake

Top
#1623745 - 08/08/2018 19:16 Re: Alfa GT JTDM 1.9 Power Loss [Re: skinflint]
Nigel Offline
Club member 123
Forum veteran

Registered: 16/12/2005
Posts: 16896
Loc: Staffordshire
My GT is now at 247,000 miles and still going very strong

Get the codes read - loss of power could be down to lots of things

Boost leak will be accompanied by a hissing noise

It could be the MAF sensor, EGR valve, swirl flaps, injectors - lots of stuff
_________________________


Top
#1623750 - 08/08/2018 22:00 Re: Alfa GT JTDM 1.9 Power Loss [Re: skinflint]
skinflint Offline
I need some sleep

Registered: 07/02/2007
Posts: 3164
Loc: West Berks
Hi Dave
Thanks for replying - I just had a dig around the front and couldn't see anything. Then started the car and it seemed like it had been, very slow pick up until I revved it a bit harder and it started to pick up better but with a bit of a stutter when I drove it at times, so I don't know if my rummaging around the hoses has changed things.

Good that your Porto is going from strength to strength.

Top
#1623786 - 10/08/2018 08:51 Re: Alfa GT JTDM 1.9 Power Loss [Re: skinflint]
skinflint Offline
I need some sleep

Registered: 07/02/2007
Posts: 3164
Loc: West Berks
Thanks Nigel 247,000 gives me hope
I'll try ECU scan on it when I get a chance

Top
#1623822 - 11/08/2018 16:11 Re: Alfa GT JTDM 1.9 Power Loss [Re: skinflint]
whatmoretyres Offline
Forum is my job

Registered: 23/08/2006
Posts: 3691
Loc: burning oil in the alfa
Easy one to check is the lower turbo hose, it rubs on the bracket and splits - Autolusso do an uprated one. When I had EGR sticking it threw the engine light straight away.
_________________________
Image oversize: limit is 5000000000000000000000gb, sorry.

Top
#1623958 - 14/08/2018 06:34 Re: Alfa GT JTDM 1.9 Power Loss [Re: skinflint]
skinflint Offline
I need some sleep

Registered: 07/02/2007
Posts: 3164
Loc: West Berks
Thanks for the advice - I'll have a closer look at the lower turbo hose. Whatever it is seemed to make it run on three cylinders for a while. It is some time since I've looked at the EGR. I've also been looking at swirl flaps on the Internet.

Top
#1623988 - 14/08/2018 19:57 Re: Alfa GT JTDM 1.9 Power Loss [Re: skinflint]
coupedummy Offline
Club member 1341
Je suis un Coupé

Registered: 25/09/2006
Posts: 8936
Loc: west bromwich
I had almost certainly the same issues on our 147 jtdm. Checked hoses, replaced afm,blanked egr still same issue without any codes.
Would be looking at turbo directly possibly.

In the end it killed itself with the oil cooler bursting dumping all its oil..
_________________________

Top
#1624053 - 17/08/2018 09:16 Re: Alfa GT JTDM 1.9 Power Loss [Re: skinflint]
skinflint Offline
I need some sleep

Registered: 07/02/2007
Posts: 3164
Loc: West Berks
Thanks Coupedummy. I've started on the swirl flap box set on Alfaowner. It seems they break off and then go through the engine and turbo from around 100,000 miles with varying levels of carnage. It would explain the way one cylinder was missing but then came back when it happened, but I didn't get any knocking from the engine at the time.

Nigel - did you do anything to your swirl flaps?

Top
#1624062 - 17/08/2018 15:04 Re: Alfa GT JTDM 1.9 Power Loss [Re: skinflint]
Nigel Offline
Club member 123
Forum veteran

Registered: 16/12/2005
Posts: 16896
Loc: Staffordshire
Originally Posted By skinflint
Nigel - did you do anything to your swirl flaps?


I have no idea if my swirl flaps are still present - I've never looked

I would expect that if I could be bothered to look, I'd find that they are all gone, especially at the mileage its done
_________________________


Top