Fiat Coupe Forum Fiat Coupe Forum
- Founded by Kayjey & James Northam - Funded by the Club for the benefit of all owners -
mixed RSS feedall RSS feeds
(this will scroll you to the RSS box)
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Old Forum BACK!
    Forum RSS feed!
    Images - finally!


» Related sites
    www.fiatcoupeclub.org
    www.fiatcoupe.net


» External data
    chatroom
    owners
 
Who's Online
3 registered (Honza, injekciona, 1 invisible), 82 Guests and 1 Spider online.
Key: Admin, Global Mod, Mod
Forum Stats
2,699 Registered Members
67 Forums
109,350 Topics
1,300,021 Posts

Most users ever online: 546 @ 30/08/2007 19:16
Top Posters
stan 32098
barnacle 31943
Theresa 22783
bockers 21004
pinin_prestatyn 19893
PeteP 18753
JimO 17908
Nigel 16976
Jim_Clennell 16261
Vickster 15915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Topic Options
#1554704 - 09/11/2015 08:24 just installed APEXI AVC-R
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
hi friends

during last weekend I have finally installed APEXI ACV-R

I found very very useful the following guide:

http://www.fccuk.org/uploads/downloadfiles/ApexiAVC.pdf

I made only 2 exit for test and the AVC-R worked great!

my only problem for now (and for this I ask your help) is the 1st gear

I have set in "star duty" menu 1st gear -50% and 2nd gear -30% of boost.

the second gear follows what I ask but not the 1st gear

I have to read max 0,7 bar on the boost gauge but the boost go over 1 bar and the wheels start spinning

my actual settigs are:

boost: 1,4 bar
duty: 60%

thanks for you help

more later I will post some pics!
_________________________

www.mecart-tube-bending.com

Top
#1554707 - 09/11/2015 09:11 Re: just installed APEXI AVC-R [Re: hangar1138]
Flea Offline
club member 251
Forum is my life

Registered: 17/12/2005
Posts: 5403
Loc: Castle Combe
You cannot go below minimum wastegate preload. SO if you have a 0.8 or 1bar actuator, that is the lowest boost threshold.
_________________________



Top
#1554709 - 09/11/2015 10:15 Re: just installed APEXI AVC-R [Re: hangar1138]
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
thanks Flea

I understand, and you're are right my actuator also just new installed and my garage told me that used a 1bar actuator

I will forgot the 1st coat

it's enough that I can lower down to 1 bar in 2nd gear

second doubt about AVC-R:

the APEXI is designed for 5 gear and I have 6 speed gearbox: what happens in 6th?

really difficul to fully test 6th gear on the road....
_________________________

www.mecart-tube-bending.com

Top
#1554741 - 09/11/2015 21:35 Re: just installed APEXI AVC-R [Re: hangar1138]
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
as promised some pics of the work:

click to enlarge
click to enlarge
click to enlarge
click to enlarge
click to enlarge
_________________________

www.mecart-tube-bending.com

Top
#1554797 - 10/11/2015 17:25 Re: just installed APEXI AVC-R [Re: hangar1138]
deannn_20VT Offline
My life on the forum

Registered: 12/08/2006
Posts: 1876
Loc: Poland
Your don't have to use "boost by gear". Btw, "Boost by gear" with regards to your setup is not actually by gear but by speed wink in case you didn't know that and you can read more on this subject here - http://www.enginebasics.com/EFI%20Tuning/Boost%20By%20Gear.html

Let's not forget that you can adjust the actuator spring preload. if there is enough thread on the actuator stud you might be able to reduce it to the desired level of 0.7b.


Edited by deannn_20VT (10/11/2015 18:04)
_________________________
Self-built forged 20VT lump running GT2871R turbo, EMU Stand Alone & pushing true 350bhp & 350lbft.

Top
#1554838 - 11/11/2015 09:15 Re: just installed APEXI AVC-R [Re: hangar1138]
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
I spliced 3 cables from ECU:

- speed
- throttle
- rpm

in my AVCR there is a section called "gear judge" where you can read the ratio between speed and rpm

you have to read this ratio for each gears and input these numbers in the APEXI EBC and done! you have boost by gear

about your advice on spring preload for now is good 1 bar for have more stable boost at high rpm

I will use 1st to move wheels and after in 2nd 1,1 bar and so on ....
_________________________

www.mecart-tube-bending.com

Top
#1554839 - 11/11/2015 09:23 Re: just installed APEXI AVC-R [Re: hangar1138]
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
next monday I will be on dyno to test the engine hp

my garage told me to set up the bost in the following way:

2000 - 4000 rpm 1,5 bar
4000 - 5500 rpm 1,3 bar
6000 - 7000 rpm 1,2 bar
_________________________

www.mecart-tube-bending.com

Top
#1554845 - 11/11/2015 11:52 Re: just installed APEXI AVC-R [Re: hangar1138]
deannn_20VT Offline
My life on the forum

Registered: 12/08/2006
Posts: 1876
Loc: Poland
Standard turbo or uprated? Is the car going to be mapped / chipped?
_________________________
Self-built forged 20VT lump running GT2871R turbo, EMU Stand Alone & pushing true 350bhp & 350lbft.

Top
#1554851 - 11/11/2015 13:04 Re: just installed APEXI AVC-R [Re: hangar1138]
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
I have GT28R

on dyno to check performance after many mods....
_________________________

www.mecart-tube-bending.com

Top
#1555335 - 16/11/2015 19:52 Re: just installed APEXI AVC-R [Re: hangar1138]
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
bad ... bad ... bad news

today I went on dyno and my car goes only at 240 BHP banghead

in the 2011 I was live mapped and I reached 290 BHP !!

some things changed:

- stainless steel 2,75"
- pro-alloy sip
- boost pressure higher
- only more 15.000 km of engine

what happens??

- dyno non calibrated correctly
- serious problem with the car

this link is the run in 4th gear from the Apexi display (it was at 75% duty now set to 80%)

https://www.dropbox.com/s/yuo7d21g79kv4q8/2015%2011%2016%20dyno.MTS?dl=0

every help is appreciated
_________________________

www.mecart-tube-bending.com

Top
#1555347 - 16/11/2015 21:57 Re: just installed APEXI AVC-R [Re: hangar1138]
nick_d Offline
My life on the forum

Registered: 10/10/2006
Posts: 1829
Loc: kidderminster
Is this the same dyno used as when your car made 290 bhp
If not dynos can vary massively also maybe that 240 figure is "at the wheels"??

Surely you would notice a difference of 50hp?
Does the car feel as quick as before with your latest mods??

Boost leak??

If I were you I'd carry out a compression test to check the condition of the engine, saying that though a few years ago my engine was massively down on compression but still made good power... ???
_________________________

368bhp @ 1.5 bar

Top
#1555362 - 17/11/2015 06:59 Re: just installed APEXI AVC-R [Re: hangar1138]
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
hi Nick

answering to you questions:

- not the same dyno
- the 240 BHP was at the engine
- I feel my car very fast I estimate around 300 BHP
- the A/F ratio is OK during all RPM run
- no boost leak

maybe engine out of compression?
maybe dyno not calibrated?

we have boost, we have rpm we have (according to dyno) little torque
_________________________

www.mecart-tube-bending.com

Top
#1555365 - 17/11/2015 08:23 Re: just installed APEXI AVC-R [Re: hangar1138]
nick_d Offline
My life on the forum

Registered: 10/10/2006
Posts: 1829
Loc: kidderminster
Easy test you can do, using private test track of course smile

According to "torque stats" calculator, which I've always found tone quite accurate...
Your car with 240 bhp will do 60-100 MPH in approx 8.5 secs,
With 300 bhp it will do it in 6.5 secs, a WHOLE 2 seconds quicker.

I predict the dyno is a little out of calibration.
Before carrying out the above test I would still do COMPRESSION test first... smile
_________________________

368bhp @ 1.5 bar

Top
#1555370 - 17/11/2015 08:58 Re: just installed APEXI AVC-R [Re: hangar1138]
deannn_20VT Offline
My life on the forum

Registered: 12/08/2006
Posts: 1876
Loc: Poland
240bhp at the engine is very low. Are you sure the afr was ok? Can you post a picture showing afr, boost and torque?

It is just a guess but you shouldn't need as much as 80% duty to reach 1.4b if your Spring is set to around 0.8 - 1b. I only need 46% with Mac solenoid and around 36% with Apexi (when I had it).

I am sure that flea will be here to help soon.
_________________________
Self-built forged 20VT lump running GT2871R turbo, EMU Stand Alone & pushing true 350bhp & 350lbft.

Top
#1555373 - 17/11/2015 09:14 Re: just installed APEXI AVC-R [Re: hangar1138]
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
thank you Deann for the support

I'hanven't a picture of the afr but I checked this morning it was around 12,5 with full throttle

you are right I tried 80% duty but this morning overshoot I go back to 75% (my spring is 1 bar)

I will try in next days another dyno because I fell my car very fast much more than the stock set-up
_________________________

www.mecart-tube-bending.com

Top
#1555400 - 17/11/2015 15:38 Re: just installed APEXI AVC-R [Re: hangar1138]
deannn_20VT Offline
My life on the forum

Registered: 12/08/2006
Posts: 1876
Loc: Poland
As far as I know your afr is a bit too high (should be very close to 12) but still I don't think that would justify 240bhp.
_________________________
Self-built forged 20VT lump running GT2871R turbo, EMU Stand Alone & pushing true 350bhp & 350lbft.

Top
#1555404 - 17/11/2015 17:13 Re: just installed APEXI AVC-R [Re: hangar1138]
deannn_20VT Offline
My life on the forum

Registered: 12/08/2006
Posts: 1876
Loc: Poland
Have a look here - http://www.fccuk.org/forum/ubbthreads.php?ubb=showflat&Number=1408260&page=all
You will find there afr data for a few coupes with different setups.
_________________________
Self-built forged 20VT lump running GT2871R turbo, EMU Stand Alone & pushing true 350bhp & 350lbft.

Top
#1589971 - 08/12/2016 09:46 Re: just installed APEXI AVC-R [Re: hangar1138]
hangar1138 Offline
Club member 1472
Making a profit

Registered: 10/04/2008
Posts: 244
Loc: Italy, Reggio Emilia
I write after 1 year of worries and anger for my nov2015 dyno gone wrong...

My car came back from my usual garage and we made 2 dyno run in 2 different days

first run: 295 HP with one or more ingnition coil defective
second run: 308 HP with all 5 ingnition coil in perfect working conditions

now I feel better I'm in line with car mods and turbo pressures

so for summary:

2011 - 287 HP (missing some mods expecially 70 mm exahust)
2015 - 240 HP
2016 - 295 HP defective coils
2016 - 308 HP healty coils

thanks for support friends!
_________________________

www.mecart-tube-bending.com

Top
#1592674 - 24/01/2017 19:31 Re: just installed APEXI AVC-R [Re: hangar1138]
Spoonz Offline
Making a profit

Registered: 14/10/2009
Posts: 289
Loc: Boston, UK
excellent news! 308bhp @ engine is perfect and should be plenty fast enough, and if set up right, it will certainly shift, my coupe is around 270bhp and that feels fast enough.
_________________________

Top
#1623895 - 13/08/2018 01:43 Re: just installed APEXI AVC-R [Re: hangar1138]
Benharris24 Offline
On a journey

Registered: 22/10/2016
Posts: 159
Loc: Southampton
Can you tell me the wire colour i need for this as installing one on mine into ecu harness

Top
#1625089 - 18/09/2018 14:15 Re: just installed APEXI AVC-R [Re: hangar1138]
kj16v Offline
My life on the forum

Registered: 12/02/2008
Posts: 1704
Loc: London
Here's the wiring I used on the last AVCR that I wired installed for a Coupe 20VT owner.

AVCR red - indicator stalk orange (because it needs to be a thick high-current wire)

AVCR green/black - ring terminal on ECU hanger

AVCR purple - ECU 6, blue

AVCR grey - ECU 53, blue/red

AVCR white - ECU pin 9 grey/red

Top
#1625102 - 18/09/2018 20:40 Re: just installed APEXI AVC-R [Re: hangar1138]
Benharris24 Offline
On a journey

Registered: 22/10/2016
Posts: 159
Loc: Southampton
Thanks Kj

Top
#1625195 - 21/09/2018 11:42 Re: just installed APEXI AVC-R [Re: hangar1138]
kj16v Offline
My life on the forum

Registered: 12/02/2008
Posts: 1704
Loc: London
Happy to help smile

Top