Fiat Coupe Forum
- Founded by Kayjey & James Northam
- Funded by the Club for the benefit of all owners
Fiat Coupe Club UK
join the club
Fiat Coupe Forum
 
» Announced
    Posting images


» Related sites
    Main club site
    fiatcoupe.net


» External data
    owners listed
 
Who's Online Now
2 registered members (Gunzi, 1 invisible), 32 guests, and 1 spider.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums67
Topics109,761
Posts1,304,140
Members2,773
Most Online546
Aug 30th, 2007
Top Posters(All Time)
barnacle 32,125
stan 32,098
Theresa 22,819
bockers 21,009
PeteP 19,020
JimO 17,908
Nigel 17,061
Jim_Clennell 16,312
Vickster 15,915
RSS Feeds
Club Events
Club Information
Track Events
Rolling Road/RWYB
Social Events
Non-UK Events
Coupé Related Chat
Coupé Spotting
Coupé News/Press
Buying/Selling Advice
Insuring a Coupé
Basic FAQ's
How to Guides
Forum Issues
Technical Problems
General Maintenance
Styling
Tuning
Handling
ICE and Alarm
Coupés for Sale
Coupés Wanted
Parts for Sale
Parts Wanted
Group Buys
Business Forum
Other Vehicles for Sale/Wanted
Other Items for Sale/Wanted
Haggling/Offers
Ebay links
Other Cars
Other Websites
General Chat
Previous Thread
Next Thread
Print Thread
Blower #1631521
07/04/2019 09:18
07/04/2019 09:18
Joined: Apr 2013
Posts: 1,074
Berkshire
AnnieMac Offline OP
Enjoying the ride
AnnieMac  Offline OP
Enjoying the ride

Joined: Apr 2013
Posts: 1,074
Berkshire
Why does the blower in my Coupe come on for a few blasts sometimes when it is switched off?


[Linked Image]
Re: Blower [Re: AnnieMac] #1631527
07/04/2019 10:59
07/04/2019 10:59
Joined: Dec 2014
Posts: 344
uk
OnlyItalian Offline
Making a profit
OnlyItalian  Offline
Making a profit

Joined: Dec 2014
Posts: 344
uk
I've had that on both my coupes but only when the battery is very weak. Coincidence?


"Proud owner of LE141 and a 99 VIS broomie "
Re: Blower [Re: AnnieMac] #1631538
08/04/2019 08:12
08/04/2019 08:12
Joined: Dec 2005
Posts: 337
Leicester
Dan Offline
Club member 1124
Dan  Offline
Club member 1124
Making a profit

Joined: Dec 2005
Posts: 337
Leicester
Mine does this too. Happens when I go over a bump, so I assume it's a dodgy contact or something's loose somewhere.

Re: Blower [Re: Dan] #1631543
08/04/2019 12:27
08/04/2019 12:27
Joined: Dec 2005
Posts: 1,166
Pontefract, West Yorkshire
andyps Offline
Club member 1482
andyps  Offline
Club member 1482
Enjoying the ride

Joined: Dec 2005
Posts: 1,166
Pontefract, West Yorkshire
Originally Posted by Dan
Mine does this too. Happens when I go over a bump, so I assume it's a dodgy contact or something's loose somewhere.


Mine has done that since I got it. It switches between the auto and slowest fan speed itself, typically when going over bumps. As I've had it for 15 years and 170k miles I guess it's not going to change and I'm not worried about it!


Andy

[Linked Image]
Re: Blower [Re: andyps] #1631557
08/04/2019 17:22
08/04/2019 17:22
Joined: Dec 2005
Posts: 19,906
North wales
pinin_prestatyn Offline
Forum veteran
pinin_prestatyn  Offline
Forum veteran

Joined: Dec 2005
Posts: 19,906
North wales
Mine was the wires below the glove box.



Coopless!
Re: Blower [Re: AnnieMac] #1631635
12/04/2019 07:47
12/04/2019 07:47
Joined: Apr 2013
Posts: 1,074
Berkshire
AnnieMac Offline OP
Enjoying the ride
AnnieMac  Offline OP
Enjoying the ride

Joined: Apr 2013
Posts: 1,074
Berkshire
Just a Coupe quirk then. It makes me jump sometimes!


[Linked Image]

Powered by UBB.threads™ PHP Forum Software 7.7.1
(Release build 20190129)
PHP: 7.3.2 Page Time: 0.019s Queries: 14 (0.007s) Memory: 0.7643 MB (Peak: 0.8209 MB) Data Comp: Off Server Time: 2019-04-25 10:24:21 UTC